Background Sound doesn't work in Designer

I created audio to use as background sound for a 3D animated scene I’m using for my project, but no sound plays when I try to view it on phones. I’ve tried saving the audio as different file types and even tried using the sample sounds that come with Designer, but it still doesn’t work.

Does anyone know if it’s possible to use background sounds anymore in Designer?

A work around I found was using a tap action to trigger the sound. But I’d really like to avoid requiring users to click to trigger the sound. They already have to make 4 clicks just to get to the experience which is already asking a lot for someone to do.

I tried looking for resources on the subject but everything I’ve found has been for Designer (Legacy).

Any help will be greatly appreciated.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Hi there! Out of curiousity, what device are you viewing the experience on?

Some devices (I believe iOS is notorious for this) limit what sounds autoplay in WebAR experiences.

Unfortunately I’ve just been testing on iPhones right now.

Ya that sadly seems true. It doesn’t seem like they pay much attention to the forum.

Ah, I would suggest trying to find an android device to test it on as well. You could also try posting a slimmed down version of your file here, or sending it to Zappar support.

In the meantime, these forum threads might be helpful, even though its a different platform:

Thanks for sharing the thread @abiro, I’ll have to check it out.

That’s a good idea, I’ll have to test it on an android device over Thanksgiving. I’m not sure how to share my file here, but I’ll see if I can share my target image and a screenshot of my settings.

Appreciate the help!

Here’s a screenshot of my project with the background sound selected

Thankfully I have an android :wink: (OnePlus 7T, she’s a few years old but gets the job done)

The audio automatically played just fine on my device, which leads me to believe it’s a limitation with iOS (possibly safari, not sure what browser you use. I use Chrome on my phone)

From what I understand, iOS’s tighter limitations prevent audio from automatically playing. I can’t recall if this is in all scenarios or not…

If you can double check that your sound isn’t muted elsewhere (I know my coworker forgets to toggle her sound switch on her iPhone a lot) and the audio still isn’t playing, you may just have to put a sound button into the experience. I know it’s not ideal, but if the sound is important to the experience, it’d be worth the extra button tap.

Otherwise, reach out to zappar support or sit tight here. Hopefully someone who’s more knowledgeable on Designer than I am can chime in

Thanks so much for testing it @abiro that means a lot!

My phone isn’t muted, so I’ve been trying to look more into what’s going on but haven’t found much.

More than likely I’m just going to have to add a button to trigger the sound.

Zappar’s support only helps when you have a paid plan (which I don’t), so I won’t hold my breath for them to look into it.

Thanks so much everyone that replied to my original post.

No worries. Wish I could be of more help.

Once I got home from the office, I did some Googling to confirm my suspicions that autoplay won’t work on iOS mobile devices. And it looks like I was correct, it’s not possible on iOS. At least, not without some coding.

If you felt like dabbling in Studio, I usually get around the autoplay issue by having the audio file play once the tracking image is seen. There’s a bit of trickery going on as I also have some onboarding screens that direct the user to point their device at the screen. You could also tie the audio to a “play” or “start game” button and just have it loop forever. Not too sure if there’s a way to do that in Designer.