Can't export .POD


#1

Hi guys! So I’m trying to export this thing here from Blender: https://blend-exchange.giantcowfilms.com/b/4192/

So that I can import the pod file to Zapworks Studio. But I kept getting this error message and failed to export the .pod. Can someone give me a hint? I tried asking on Imagination forum but got no reply :frowning:

Thanks a lot guys, appreciate any help

Error: An exception has been raised in the python script
bpy_prop_array[index]: index 3 out of range
File “/Applications/blender.app/Contents/Resources/2.79/scripts/addons/PVRGeoPODScript.py”, line 827, in AddScene
AddObject(pvrgeopod, obj, -1, True)
File “/Applications/blender.app/Contents/Resources/2.79/scripts/addons/PVRGeoPODScript.py”, line 724, in AddObject
id = AddMesh(pvrgeopod, obj, parentID)
File “/Applications/blender.app/Contents/Resources/2.79/scripts/addons/PVRGeoPODScript.py”, line 414, in AddMesh
node.sGeomData.pMap[k].pVtx[idx].x = UVData[k][faceidx].uv[vertIdx][0]


#2

So I tried exporting it first to .dae, then importing the .dae again, then export that to .pod and it worked.
I had just to open the .pod with PVRShamanGUI to import the textures again.

Then I imported the .pod to Zapworks Studio.

However, a new problem arose and I need your help! It’s that Zapworks Studio crashed right after I dragged the .pod file to the hierarchy!


#3

Hi there,

Glad you managed to find a workaround for your first issue. However, so I can help you with your new one I’m going to need to take a look at your project. Could you please submit a support ticket at the following link, and include your project’s .ZPP file?

https://docs.zap.works/

Thanks,
Seb


#4

Hi Seb,
Thanks for your response, I just sent a message with the zpp file .

Thanks,

Pipou


#5

Hi Pipou,

Thanks for that, your support ticket was received so I’ll be contacting you on there directly.

Thanks,
Seb


#6

Hi Seb,
If you found any offline solutions to help Pipou, please share! I’m having the same issue and am trying to resolve it from the Imagination PVRSDK end. So far, still errors. It’s increasingly frustrating trying to get a 3D model into ZAPPAR. If you could make a step by step tutorial from blender to ZAPPAR, that would be awesome!
thanks!
Mindy


#7

Hi Mindy,

In the end I found that the model Pipou was trying to import had a few issues with it.

Firstly, the POD export had cameras, lights and particle emitters, which are currently not supported by Studio.

Also, the texture files had not been assigned correctly on exporting the POD file.

However, the main issue causing the crash was the fact that the model did not used interleaved vertex data, whereas Studio only supports interleaved models.

I linked Pipou to the following docs page, it may come in handy for you too.

Hope this helps.

Thanks,
Seb


#8

I’m having a similar issue. My model has no textures and it’s not really that complex. Any help would be greatly appreciated!

-Felix

dog.obj (188.2 KB)


#9

Hi guys, just to let you know that importing FBX files works pretty well…


#10

Hi Felix,

Judging by your screenshot, it looks like the error lies with the PVRGeoPOD plugin on your Blender software.

You’ll have to refer to either the Blender or PVRGeoPOD support channels for help with that specific error message.

In the meantime, you could send your 3D model over to support@zappar.com, in case we’re able to find an issue with the model.

Thanks,
Seb


#11

Hello, has there been any resolution to this? I have the exact same error. Did you find any sort of work around?


#12

Check out this reply from PVRGeoPod team, they gave an update to the python script to fix this:


#13

Thank you for your reply. I did see the post already, but there’s no file to pull up that I can see or get to. Is there something I’m not seeing on this post?


#14

So weird! Can you try replacing this file with the python script you have? PVRGeoPODScript.py.zip (9.4 KB)


#15

I downloaded from the link you provided, updated file and restarted Blender, but it gave the same error. I tried the way suggested by a previous poster (khongcogighegom) and did the .dae workaround, That did allow me to export a .pod, although now I can’t see my object in Zapworks Studio. I’m only seeing the cube with the 3d arrows. I’ve scaled down my object (.01) and still nothing.


#16

■■■■. What about exporting it as a .fbx?


#17

Exporting in as .fbx worked, but the animation is completely distorted. Still won’t display my object or animation with the .POD.
I did however get the POD to export without the .dae workaround, not sure what I did or didn’t do. I tried a many more exports logging small tweaks as I went. I believe what worked for me was checking the “Align Vertex Data” checkbox under the Geometry tab of PVR export tool. Although I tried again later and unchecked the box just to verify and it had been what worked for me. The .POD still worked, so in short, I have no idea.
Is there a way for me to send my files to either you, or someone there at Zappar so we can find is happening with the animation? Hopefully I can be told specifically what I’m doing wrong and share here on the boards for anyone else that may be/or will be struggling with the same thing in the future.
Thank you in advance for your time


#18

Hey there,

Could you please send your pod and fbx files in to support@zappar.com.

If we manage to find the cause of the issue I’ll post an update on this topic.

In the meantime could you please double check that the 3D model itself adheres to Studio’s 3D limitations, and that the recommended export settings have been followed.

Thanks,
Seb