Zapworks CLI not working


#1

Hi, I’m trying to train images for tracking with the zapworks cli but I get this error when I execute “zapworks”. Am I doing something wrong?. I used “npm i -g @zappar/zapworks-cli” to install the command line.


#2

Hi @max.ojeda,

I’ve got a couple of questions which will help us track down the issue:

I see you’re using Windows. Which windows are you running on (10?) 32 or 64 bit?
Does it throw the same error if you try training an image zapworks train path_to_image.jpg?


#3

Hi @deimantas, yeah it throws the same error with that command. It’s a 64 bit system (windows 10)


#4

Thanks for getting back with the windows version :slight_smile:

Which versions of node/npm do you have installed?
You can check this by running npm -v and node -v in cmd


#5

This are my node and npm versionversion


#6

Maybe npm is pointing to the wrong directory? I would suggest confirming that node modules are indeed being installed to the path seen in the error you’re getting.

npm config get prefix

Might reveal some more info :slight_smile:


#7

Hi @deimantas. I run that command, it shows “C:\Users\Max\AppData\Roaming\npm”.


#8

was this resolved. I’m having the exact same issue