Zapworks CLI not working on MacBook Pro & ZIP folder 404 error message


#1

I have been using the Zapworks CLI tool for a few days.
And it just stopped working.
I tried uninstalling it and re-installing it multiple times.
And it’s installed just fine, but I always get this message:

zsh: command not found: zapworks

Then, I tried uploading a zip folder with the index.html file, and it failed too:
https://efxg.zappar.io/9099775273619833332/1.8.0/
Message:

404 Not Found

  • Code: NoSuchKey
  • Message: The specified key does not exist.
  • Key: efxg/9099775273619833332/1.8.0/index.html
  • RequestId: F6F43915D4AA2A0A
  • HostId: Lkzdy6BAMnjIIdGCg7nzAv1scfq0m5jrMqZm2KYBLS6CD7bWBz6NIaFzAP9asZA/Boc6SaO2MU4=

And I made sure that the index.html was present in the zipped folder.

Any help is appreciated. Thanks.


#2

Hi @developer3,

Sorry for the late response. Did you manage to get the CLI working in the end?

George


#3

Hello,

I cannot get this CLI working at all! I followed the instructions and installed it:

Thanks,
jrDev


#4

Hi @jrDev,

It looks like your global node modules path isn’t set, not 100% sure why but here’s a workaround - https://stackoverflow.com/questions/15054388/global-node-modules-not-installing-correctly-command-not-found

Let me know if that solves it!

George