WebAR startup error using Universal AR unity


#1

WebAR startup error using Universal AR unity

Hello.
I created WebAR using the unity of Universal AR.
The build of this content went well and I was able to upload it successfully.
However, when I tried to start it on the ipad safari, I got an error saying “An error occurred running the Unity content on this page.See your browser JavaScript console for more info.The error was: ReferenceError: Can’t find variable: ZCV”. I can’t start it. The system version will be 15. I tried it at 14, but it didn’t work. It starts without any problem in chrome. Also, on iPhone, Safari and chrome will start without any problem. Only the iPad doesn’t work. I asked other users to try it, but only the ipad safari doesn’t work. It’s very troubled. Help me.

Here is a sample URL.
https://rry.zappar.io/5722939952636223364/1.0.24/index.html


#2

Hi @nagasawa.f,

thanks for bringing this issue to our attention. We have identified the issue and it seems that the Safari on iPad tries to request a MacOS site which is weird. Anyways please find the patch fix for this as a new WebGLTemplates folder in the attachment.

You’ll need to replace the existing WebGLTemplates folder located inside com.zappar.uar@xxxxx (project/dir/Library/PackageCache/) with this new Templates. Please note that directly replacing this within Assets is not reliable since it’s updated every time Unity is reloaded.

Let us know how you get on, or have any other issues.

Cheers,

WebGLTemplates.zip (4.7 KB)