Video frame not appearing in Android WebAR

So interesting issue here.
I have an embedded video in my experience that plays upon tap. It works beautifully in Safari WebAR and the Zappar App, but for Android (I’ve tried both Chrome and the Samsung Browser) the video does not appear on the first load of the experience. When you reset the timeline, it shows up just fine. I’m not quite sure what’s going on here. The way the controller/timeline is set up is I have the video restarting at 0ms, and then pausing at 10ms. Anyone have any insights?

I’m trying to avoid having to load in a PNG of the first animation frame since overall .zpp file size is of concern. Like I said, it works fine on Safari. We tried it on an iPad Pro 2, iPhone 11, OnePlus 7T, and a Samsung Galaxy Tab A. Only the android devices had an issue.

Coming back for anyone who stumbles upon this.

This is a known bug with no current fix, so the only option is to use an image (jpg or png) that disappears upon tap

Hi abiro,
if you start the video on “ready” and after 300 you pause it and then restart it on tap it should show up…
Let me know if it works…

Hay @abiro
Can you explain how you are using the controller/timeline with your video?

I had some problems in the past and was told I should use code over timelines when playing with videos.


I’m still a code newbie so I rely heavily on timelines to make things work.
Here’s my controller. “preTap” and “Anim” are timelines, “Disabled” is a state.

preTap timeline:
(mp4 resets at 0ms, then pauses at 1ms)

Anim Timeline:

So the way it’s set up, the video starts hidden in the Disabled state. The user then taps a button during the onboarding/tutorial screen that plays the preTap timeline. Then upon tapping an invisible plane layered over the mp4, the Anim timeline plays.

This is just one level in a multi-level experience, once the user finds everything, they can return to the menu and choose another level, hence the disabled state.

If using code would be easier and not take too much time, I’m willing to learn (eager to, really. i just don’t have the time at the moment). It’ll be a few days minimum before I can get to this section of the experience anyway, so while it’s sort of a pressing thing to resolve, it’s not urgent


I’ll have to give that a go when I circle back to this part of the project. I’ll report back if/when I do!