Unity URP WEBGL iPhone not showing camera feed when deployed

Ok, this is very awkward as I don’t see anybody getting the same problem as me so I’m looking for some guidance.

I’m trying to build a simple image tracking WebAR website using Unity 2021.3.22 URP and Zappar without success because every time I want to access the website I can only see my 3d Model but no camera feed (black screen) on my iPhone.

I want to say I did checked everything like changing the project to SRP, update the scene, update the project for building, add and re-add zappar camera and zappar image tracking (no unity cameras) but every time I access the website, there’s a black background screen instead of the rear camera feed.
I also selected the correct template in Player → Resolution

I am self hosting my project over the web by uploading the build to itch.io, but I don’t have any webcam to test in Unity editor or PC web.

Here’s the link:

What I have done:
Tested with Unity 2021.3.22 URP
Tested with Unity 2021.3.22 3D Core (Non Scriptable render pipeline)
Tested with unity 2019.4.40 URP
Tested with Unity 2019.4.40 3D Core (Non Scriptable render pipeline)

Downloaded one of the sample projects, changed Unity to WebGL, build and host on my site, same black screen.

Tested the QR from the above sample project on my Iphone worked (so it’s not my phone)
Tested on my iPhone 12 Pro, iOS 16.3.1 (Haven’t updated to the recent iOS 16.4)
Tested on my iPhone, Safari.
Tested on my Iphone, Chrome

Oddly enough, I tested the website on and Android device (Chrome) and it worked pretty well.
One thing I must say is that every time my phone tries to access the website and ask permissions for the camera, after accepting, the camera indicator turns off as a symbol of stopped working.

Am I missing something?
I’ve spent 2 days trying to make it work with no luck and I’ve almost given up.

Hello @poditok538

This seems more like a permissions issue, than Unity project setup or UAR. Specially in this case where you have a cross-domain iframe, the permission granted for iframe may not be the same for host page “itch.io” as well depending upon the browser vendor. Despite the raised prompt and user allowing the permission requests.

Can you try implementing another permissions dialog on the host page of itch.io which is called maybe before/after Unity WebGL is loaded? And see if that helps.