No Animation in 3d


#1

I’ve been going over this issue for hours, but I can’t seem to figure this out… Hopefully someone has an answer. No matter what I do, I can’t get 3d animations to play in Zapworks Studio. I’ve downloaded PVRShaman, and all of the related plugins, and I’ve installed them into the proper places for blender. It’s a fairly simple animation… Just a car going around a track. I’ve tried with, and without bones/armatures. When I right-click to view the 3d file’s, properties from the “Media Library” in Zapworks Studio… it shows that it has 60 frames of animation, but it doesn’t show anywhere else as a timeline. This is true from both my Mac, and my PC. When I bring the file into PVRShaman, it shows the animation working properly… I’m sure I’m just missing a step, or a setting somewhere. Any help would be GREATLY appreciated.


#2

Hi there,

We recently updated our documentation to be a bit clearer on the process of playing a 3d models exported animations which can be found here - https://docs.zap.works/studio/3d-models/playing-3d-animations/

If this doesn’t match what you have in your project it might be an issue with the animation not having exported correctly, please let us know at what stage it starts to differ for you.

Mark


#3

When I bring the 3d model with animation into Zapworks Studio, no animation is shown. In your example videos, the animation shows up as a “symbol definition”, and shows up in the “properties” palette, under “references”. No matter what I try, this doesn’t seem to be the case.


#4

A colleague and I seemed to have figured it out… It seems that my issues with Zapworks Studio lie in a program bug… If you click the “+” button to upload your 3d file with animation, it will not include the animation data… If you drag and drop your “.pod” file into the area that says “Drop files to import here”, everything works just fine.

Also, if you’re a blender user and you’ve used the Cycles render engine to build your scene, and bake all of your textures… You’ll have to convert everything over to the blender internal render engine setup, relink all of your baked textures, and export the “.pod” file before Zapworks Studio will allow you to add your textures.


#5

Glad to see you managed to resolve the issue, i’ve passed your feedback onto the platform team to fix the plus button drop down import for 3d models.

your project looks super cool by the way, we’d love to see the finished product :slight_smile:


#6

I seem to have this same problem unfortunately. I am unable to drag and drop files to import them and using the “+” to import the FBX doesn’t seem to do anything either. It says the file is imported and shows in the library but no physical object is in the viewport once dragged into the hierarchy. I’m also not getting the import options usually associated with importing an FBX.
I’ve been scratching my head for hours over it until reading this post. Is there any work around?

Thank you in advance


#7

Hi @metafuel,

Would it be possible for you to send a copy of the FBX to Support@Zappar.com so we can look into finding a solution to this problem.

Until then, please check out our documentation on 3D models, as this explains the supported formats and how to export/import into Studio.

Looking forward to solving this problem for you! :slight_smile:

Thanks,

George


#8

Hi George - thanks so much for the fast response. Really appreciated.
I tried multiple FBX’s and animated FBX’s to no avail. I have now re-installed my copy of ZapWorks Studio and I’m now able to drag and drop files and the correct import dialogues for FBX appear.
Thank you again for the fast response. Have a fantastic weekend.