Multiple video's longer than a minute each causing issues on various devices


#1

Hi team Zappar,

I’ve been having trouble using video’s on certain devices. In short: the video’s do play as they should, but on certain devices (like the Samsung J4+ and Iphone 6) it refuses to load a second video after closing the first one. It just won’t start. On the other hand: it works just fine on the iPad 2 and Xiaomi Pocophone F1.

I’m letting controllers decide which video is present in an object and use a script to play and pause a video via objects that are buttons. The video’s are H.264 MP4 at a 800kb/s bitrate.

Before posting any code here, this is how the app is build up: Is this a known issue and if so, is there a workaround?

Best regards,
Team academy

edit: So I’ve found the source of the problem. I have created two Zappar instances. One with short video’s (20 - 30 sec) and one with longer video’s (60 - 240 sec). The video’s have similar encoding. Could the length of the video be of a problem?


#2

Hello @academy,
I had the same problem back when I was making my ISS zap. I found you can’t use the controllers to change what video I wanted to play. I had to use code.
Mark posted some code that I used later to make things work.
Change Video URL

Hey Guys,

The following line of code should let you change the source of the video node within the video player subsymbol from the parent symbol:

symbol.nodes.VideoPlayerNodeName.nodes.show0.myvid.source("new URL");

VideoPlayerNodeName = The name of your video player symbol node in the Hierarchy, you can drag it in and use it as a variable if you run into issues with this.

Mark

Hope it helps,
Steve


#3

Hi Steve,

Thanks for your reply. I’ve tested this method and it didn’t solve my problem. It seems the length of the video is causing the issue. I edited my post with these findings.

Thanks,
team Academy


#4

Hi @academy,

Would it be possible to email support@zappar.com with the examples you have been testing?

We have done some initial tests but would like to understand the flow of the problem you are describing.

When you say - I’m letting controllers decide which video is present, is this activating a state enabling /disabling the object with the video material assigned?

Looking forward to getting to the bottom of this one! :slight_smile:

George


#5

Hi @George,

Thank you for replying. I’ve send you the files.
I will update the post as soon as a solution to the problem has been found.

Thanks,
team Academy