Instant tracking testing

Having a day testing the studio and hitting some walls.

[EDIT] - this works now, didn’t realise it needed to be unlocked with that zapcode. I feel like a F O O L now haha.
[DOUBLE EDIT] - so if I understand it you have to scan a zapcode to unlock it ? The deeplink generated in the browser dashboard doesn’t act as a get-around for this step ?

Have published a basic instant tracker here - Zappar for Web (v1.1.62)
which gets stuck in the scanning phase doesn’t deploy anything. Have I formatted my Url incorrectly ?

Your own greek jar demo works fine so I’m wondering what I’m doing wrong here.

following the directions here btw. Testing on iphone X and pixel 2.

Here’s my screenshots of the two attempt I’ve made - #1 taking the zpp file (rom the above link) and sticking it in the symbol defs panel. The other one (#2) I imported a zpp file ( linked from a forum post )into the project and stuck the zapbot on that.

…As a side note - if you get the zid in the URL wrong should it flag it up as there being nothing there ?

Have just tried publishing the world tracking example template straight into another URL as that’s stuck in scanning mode also. Going to go back a read the docs again because this is turning out harder to get my head around than the Universal AR stuff :open_mouth:

[EDIT] - this example works fine - I didn’t know you had to scan a zapcode to unlock it - thought it just needed to scan a surface and that was it ! The world tracking example gives me a ‘device does not support this’ on iphone X and ipad pro 3 which is a bit suspiciuos. Also the tracking is pretty bad ( compared to the greek jar example which is lovely)

Anyway will go back to the above example and get that working now hopefully…

Haven’t been here for a while, so something may have changed in the meantime, but … the zid on the end of your URL doesn’t look like a proper ID to me. It looks more like a shortcode (the type used by the redirect server).

If you follow the link for the greek vase project above, in your address bar you’ll see you’re redirected from the link to a different (longer) URL:

The actual zid for the greek vase is z/Sfek1c.

You can find the ID on your Zap Projects page (you need to look for a “Deep link ID” - can’t remember where exactly you have to go to find it) or alternatively, if you have a working link, watch where it takes you - you’ll see your project’s zid in the URL. Stick that on the end of Zappar for Web (v1.1.62) and all should work properly, no need to rescan a zapcode :slight_smile:

Hi @jerry,

First of all - welcome to ZapWorks! :tada:

Hopefully I can clear up some confusion for you. To start with, I thought I’d share some helpful doucmentation to provide context.

  • ZapWorks Studio | Getting Started - You’ve already found our documentation site, but I really recommend going through the ‘Getting Started’ section as it lays a lot of the groundwork for working with ZapWorks Studio.
  • General | Project Triggers - This will take you through all of the methods you can use to launch your experience. In this case, the URL you shared is a Deep Link trigger type.
  • Distribution Methods - This will explain what platforms can support your experience. As you’re looking to create an Instant Tracked experience, the WebAR article will be most helpful here.

Deep Link Triggers work just like regular website links and will go directly to your experience. However, to view an Instant World Tracked experience, you need to be viewing the project in one of the three websites we share here.

As you are trialing the product, I’d recommend using Therefore, to view your experience, you should first go to, then scan your QR code or Zapcode to activate it. If you are happy with how this looks and you would like your Deep Link to automatically launch in, get in touch with us at

Hopefully this is helpful!

Have a great day!

Francesca :blush:

1 Like