Imported .ZPP file not showing any .png files in viewport (but still part of the experience)


#1

Hi, Zapworks forums.

I have a viewport problem with a ZPP file I have imported into a new project. Whenever I export my working project from Zapworks as a ZPP, then reimport it back into a new project, I find that the viewport doesn’t load any of the png files it has stored.

  • The files aren’t missing. I’m able to export the PNG’s in the media library from my ZPP version to my desktop as a copy. They also don’t have any missing tags in the boxes or red underlines o show there’s a problem.

  • I tried publishing the new ZPP experience and it works with all the assets showing. It’s just the viewport in Studio from my ZPP file that doesn’t show up.

  • I’ve tried downloading the original published version from my account and importing that one also, and I’m ending up with the same problem. Everything is only fully visible in my original version or when it’s been published.

  • Texture maps on models and trained tracking images work normally.

  • What’s also strange is I have a black overlay that fades on and off at certain times in the experience to enhance the readability at certain parts, and this also doesn’t work in the ZPP version.

The best way to think of my new file is, imagine the experience is working, but the png’s or at least anything regarding the plane object type is unexplainably invisible in the viewport, but not missing from the expereince.

Any solutions? I’ve provided some screenshots below of the comparisons between the two projects.

Both experiences work normally once published. It’s just the viewport


#2

Hi @marcus2,

It sounds like the Plane object in your scene might have corrupted. I wonder if you can send over the ZPP to support@zappar.com where we can take a look?

In some cases we can clean the ZPP and it’ll fix it, if you send it over I’ll be sure to take a look and reply on this thread with the findings.

George


#3

Hi George.

I sent a file to the support address to take a look at.

Thanks,
Marcus


#4

Hi @marcus2,

I’ve replied directly but thought I’d also add the response here just in case anyone else has a similar issue.


I believe I’ve found an easy fix.

Could you please try renaming the Plane object in the Media Library to ‘Plane 2’. This should, hopefully, automatically update the scene and the objects will now appear. If it’s still playing up then you can delete the Plane object in the Media Library, head to the plus (+) icon and add a new Plane object. Again you might need to rename it to fix the issue.

I’m guessing that the Plane or linking to the Plane is corrupted. Luckily it’s not something that I’ve seen happen before so shouldn’t be a reoccurring issue. Hopefully this easy fix works for you. Please let me know!


George


#5

Hi @George

Thanks, that seems to have done the trick. It’s important to note that renaming the plane only worked when I had an underscore instead of space between.

So instead of just Plane 1, it has to be Plane_1. At least for my file anyway.

2021-07-14%2008_51_45-Window