Can't upload video

I can’t seem to upload video to Zap.Works. I’m trying to change the alpha video from the template project below to our own alpha video (.mov) but nothing happens. No error, but also no upload or other notification.

The file is approx. 60mb now, which is a bit large perhaps but still far below the specified max of 100mb. The video is 90 seconds long, which again is far below the specified max of 10 minutes.

I’ve read that transparent video can only be uploaded via Studio. But in the studio variant this template isn’t available. And there is no option to transfer this template to studio since there is no way to download the project?

Hi there! My area of expertise is actually Studio, but I did do some digging in the ZapWorks documentation for you. The supported video formats page mentions converting .mov and .mp4 files into WebM to see if the alpha channel works. Have you tried that yet?

Alternatively, have you tried uploading your video in a different supported format, such as .mp4?
Using something like Adobe Media Encoder can both convert the file type and also reduce file size, making it easier to upload

1 Like

thank you for your reply. I’ve installed the WebM plugin for Premiere and exported is as such. It did start uploading, but it’s stuck at “processing 1%” now for an hour or so.

I now also encountered this article stating only .flv is supported in designer: Designer (Legacy) | Are transparent (alpha) videos supported?

But I also noticed the article you shared saying I should be using WebM. Furthermore .flv is a non-existing codec by now. It’s a flash component, but flash got killed quite some time ago. After that NLE’s stopped supporting this format.

It’s getting quite cumbersome at this moment I must say. It’s good that there’s online documentation, but it doesn’t help if it’s contradicting and not updated.

Or is Legacy a previous version of designer? I’m not English native, not really sure what it means.

I sent out a support ticket to Zappar with a link to the WebM file I try to upload.

Tried two different video codecs. Both just stick at 1% processing



Legacy is indeed an older version of Designer. It functions differently than the new Designer, but some people prefer to still use it so I think that’s why Zappar keeps it up…for now.

As for the video getting stuck at 1%, unfortunately I’m not too sure of other workarounds since I’m pretty unfamiliar with Designer as a whole. Hopefully you get an answer soon.

You might see if using .mp4 fixes the issue, but I can’t promise anything

1 Like

But I don’t get it. The template projects already contains a transparant video file. It must be able to import it.
.mp4 doesn’t support an alpha channel right?

So I downloaded the existing file by Zappar, and noticed it indeed is an .mp4 but with the chroma green still as a backdrop.
It’s funny, because in the scene objects navigator it shows up as a WebM file. So I guess the .mp4 gets keyed and converted to a WebM within Zap.Works’ designer.

I tried uploading the same video again myself, but of course it’s not being keyed automatically. It needs to know which color to key probably, but I cannot find documentation about this process, nor can I find any settings or checkboxes for chromakey in designer. For all I know it’s magic ;-).

Unfortunately, there’s a contact form where people can submit a question/issue (Contact us)
But when using that the following message appears:

Server Error (500)

You might try directly emailing customer support at if the form is down!