[Bug Report] WebAR does not take into account tab bars on Safari


#1

Please see the attached file.

First, disable tab bars on Safari. Open webar and scan the experience. Switch the phone to landscape. You will see a small white square. Also pay attention to the x and y values(width and height of the screen, respectively).

Now, enable tab bars on Safari. Repeat the process. You will no longer be able to see the white square. The x and y values will also be the same.This happens because the tab bars take extra space from the screen and zappar does not account for that, it thinks that the space is the same when in fact it’s not.

This is a nuisance when making landscape UIs, because it’s necessary to shift the UI up to account for the case where tab bars are enabled, but it doesn’t look very good when tab bars are disabled.

The ideal fix would be zappar resizing the UI with tab bars enabled. If that’s not possible, updating the x and y values would also solve the problem, because then I’d be able to use that to update the UI myself.

test.zpp (188.1 KB)