ZapWorks CLI installation

Hey there,

sorry to bother but I have been trying to install the CLI for a few hours now to be able to use the “serve” service, but I keep getting errors during install:

Here what it shows me in terminal:

npm ERR! code 1

npm ERR! path /usr/local/lib/node_modules/@zappar/zapworks-cli/node_modules/@zappar/imagetraining

npm ERR! command failed

npm ERR! command sh -c node-pre-gyp install --fallback-to-build=false

npm ERR! response status 403 Forbidden on

I found older posts on this, but nothing recent.
I tried to point npm to the previous version, but imagetraining-v1.0.2 also seems unavailable.
Is that just a problem for the “eu-west” node it is trying to use for my location or is there something else going wrong?

Best regards,


Hey @it12,

The issue here is that the CLI did not support ARM/M1 Macs. This has been fixed today, please try to install again (version 1.0.0) :slight_smile:

npm install -g @zappar/zapworks-cli@1.0.0

1 Like

Just wanted to confirm that this worked as promised.

Thanks very much!