Zappar for Windows: update required


Hey everyone,

I’m trying to debug a project with Zappar for Windows and it is telling me that an update is required. The prompt has two buttons for rescan (does not help) and open store (loads App Store in my browser), see attached image. I’ve been getting this issue a few times before in other projects, but can’t seem to pinpoint the actual cause for it. Everything worked yesterday and works fine for another project forked from this one. The project also works fine with an actual device.


I guess it has to be something in my project / scripts, because those have changed since I last debugged. Everything working fine on an actual device is what throws me off as I feel like that indicates functional code. Wondering if anyone else has had the same problem and if a solution is known?


Hi Ero,

Could you please download Studio again from the following link and tell me if the issue is still present:

We recently updated Studio, so it may be that you’re getting the update message a bit late.

If this still doesn’t fix the issue then could you send your zpp over to for me to have a closer look?



Hi Sebastian,

Is there a way to install the new studio version in a specified location? The install behavior that forces the install into appdata triggers my Bitdefender (which immediately quarantines everything). Is this intended or something weird on my end? My previous studio version was a beta installed nicely into program files.


Had to reconfig Bitdefender a bit to use the new version but it seems the debugging in Zappar for Windows now works. That’s awesome!

Getting some funky glitches for some of my 3d assets in this new version. Had no issues in the older version. Sebastian, have we gotten any major changes to pod format rendering or something related? To me it looks like a skinning / vertex binding / bone weights issue… Any guess? :smiley:


Hi again Ero,

Glad you managed to get the install issue sorted.

In regards to your new 3D issue, could you send through your 3D models to please?

I’ll have a closer look at the models and see what might be causing the issue.



Sorry, can’t share these assets as I’m under NDA.

I’ll try to figure out what’s going on and report back if I manage to fix it.

Thank you for helping regardless!


Here, I move the ZapWorks-Studio directory from AppData (in C: drive) to another location (on D: drive), it works all right.

When a new Studio version is available, a pop-up indicates it will upgrade itself.
But instead of upgrading the directory from which it has been launched, it adds the new version to the AppData directory, and leaves our custom installation unchanged (and as our shortcut leads to our custom location, the user still launches the old version).



But I am getting windows update error 80070103 after updating the Zappar. Can anyone tell me why such kind of error is occurring? Is anyone else has faced this?


Hi Seb,

I’ve reinstalled ZapWorks Studio, but still getting same message on the desktop windows Zappar.
I’ve done it inhabilitating the norton antivirus, but it didn’t worked.

Could you help me please?


Hey there. I run in the same issue. On my site it was solved on the time i deleted the world tracking in my hirachy and deleted the symbol. But it shouldn’t be so.


I don’t think they have world tracking working in the zappar desktop yet.