Xiaomi 4X compatibility issue

Tried to test files with Xiaomi 4X but it doesn’t seem to work.
Tried also with a Xiaomi Redmi Pro and everything works.
Any ideas for this compatibility issue with 4X?

1 Like

Can you describe what happens? Are you able to install it?

1 Like

Sure! I am able to install it normally, but when I point it to the codes on the controller, it doesn’t read them. It wasn’t reading the old files with the flower and the beta button too.

1 Like

Hmm, that’s quite odd. Can you attach a screenshot of you trying to do the pairing process?

1 Like

I am having the same problem with my Xiaomi Redmi 3s prime

i hover the camera over the controller and it does not pair or even detect an object…


1 Like

1 Like

Thanks @matt.harris.1981 - I’d definitely expect it to be detected in those images. I know Xiaomi have their own skin on top of Android, but do you know the underlying Android version on your device?

There’s a couple of things I can think of - either the camera doesn’t offer a 720p preview format (or perhaps advertises it but gives us something different), or maybe the data we get has some additional padding between rows which we might not handle properly.

I’ll have a think about how we can debug this better - I don’t think we can easily get hold of Xiaomi devices in the UK unfortunately.

1 Like

1 Like

Hi Simon,

This is where it gets interesting…

I am running lineage OS (Android 6.0.1)

If there are any logs or outputs you would like from a Xiaomi device please dont hesitate to ask and i will see what i can do

1 Like

Thanks both. I’m going to pick up a 4X for Zappar’s device pool from eBay so I can debug it more easily.

@matt.harris.1981 We’ll probably only officially support stock ROMs but I suspect it’s the same underlying issue that @vasilislamprinakos is having, so hopefully will work for you too when we get it fixed on the 4X.

1 Like

Thanks @Simon! Keep up the excellent work you are doing, both you and the zap-team !

1 Like

Quick update here, the 4X arrived a couple of hours ago from eBay.

The issue is we try and use the new camera2 API on it, as it’s Android 6. The device uses “Legacy” mode through the camera2 API and doesn’t expose any of the manual modes, which is relatively common it seems. More weirdly it doesn’t list 1280x720 (720p) as a supported resolution in any of the standard preview formats through that camera2 API.

The positive news is through the old API it does expose 1280x720 preview, and actually seems to allow manual ISO settings (through an undocumented parameter) which should give decent short exposure frames with minimal blur.

I’ll mention here when there’s something to test (I’m on holiday next week though, so it will be a couple of weeks at the earliest)

1 Like

Hi, Simon!
Is there any updates about solve this problem?


Hi, same here. But android 7.1.2 on redmi 4x.
Any news? Let me know if I can help with something.

Temporarly fixed it:

  1. you need to be rooted
  2. Add in /system/build.prop : persist.camera.HAL3.enabled=1
  3. reboot phone
  4. Now the zapbox app will recognise the controller
  5. Drawback of this method is that the miui built-in camera app wont work anymore
    But you can easily replace this with another camera app. (even better apps)
    I simply use the free “Open Camera” app, which is excellent!

Tested on latest xiaomi.eu and globe-rom.

Warning: You can brick your phone if you do not know what you are doing.