WebAR Instant Tracker Scale and Position


#1

I’m using the Instant Tracker to place an object into the scene, but it appears to lose the position very easily (even while holding the device steady) resulting in the objects flickering between the intended position and center of the screen.
Additionally, when moving away from the location, objects do not appear to scale at all.

I am building for WebGL using Unity, and have tested on several devices (Android and IOS) and using multiple browsers (Firefox, Chrome, Safari).

Is there anything I can do to improve this behaviour?
Thanks.


#2

Hi @hbentley,

I believe I have answered your ticket, but just in case this is helpful to anybody:

The Instant World Tracker doesn’t understand our physical world in as complex detail as traditional World Tracking. This is because the browserdoes not permit us access to ARCore/ARKit, which allows the device to understand real-world planes. Instead, the Instant World Tracker relies on camera frames in order to anchor content.

It’s for this reason that we recommend any Instant World Tracked content is placed on a textured surface, so that the anchor has something more ‘grippy’ to attach itself to (e.g. you’ll find more luck placing content on a keyboard than you will a glass table). :rocket:

Additionally, because the Instant World Tracker doesn’t actually understand it’s place in the real world, a major shift in frames can displace it. This is because the camera feed becomes drastically different to what the anchor thinks it’s tracked to. It’s for this reason that Instant Tracked content should be in the camera’s view at all times. This is also the reason as for why getting too close to the object can move it - I’d suggest making some sort of warning or other kinds of handling to let the user know that they are too close or too far.

You also want to make sure that you are using the latest version of the Universal AR for Unity SDK, and that you are using the correct WebGL template for the version of Unity you’re working in. We’ve also found that using the Zappar Menu and going to Editor > Update Project Settings To Publish just before building projects can eliminate some issues, such as those relating to loading or frame rate.

Have a great day!
Francesca :blush: