Web gl build grey screen

trying out the samples, after the loading bar the screen just show grey
anyone has this problem?
im using the unity-example-instant-tracking-cloth-physics

unity 2020.3.34

Hello @sidchou93

Welcome to the forum.

Can you post the console logs here which might hint at what’s causing the issue?

Further, are you getting this issue from github page here, or in your own local copy of the examples repo? If it’s the later please make sure your build settings are up to date depending upon Unity version and target platform. I suspect this may due to WebGL compression setting which varies between Unity version 2019 (used in examples) and 2020 (your version). A quick solution maybe to just use Zappar/Editor/Update Project Settings To Publish.


Zappar CV v0.3.12 zappar-cv.js:9:29670
Loading failed for the <script> with source “https://d9003.zappar.io/1851770358319192628/1.01/%UNITY_WEBGL_LOADER_URL%”. 1.01:87:1
Uncaught (in promise) ReferenceError: UnityLoader is not defined
WaitForZCVLoad https://d9003.zappar.io/1851770358319192628/1.01/:99

heres the link, i simply download the example and change the build to not 2019 and upload for a test

Yup seems like it due to incorrect WebGLTemplate!

Please read through the WebGL section from Readme.md to understand the optimum build settings and WebGLTemplate respective to Unity versions. Another quick option is to just use Zappar/Editor/Update Project Settings To Publish from Unity editor menu option.



i tried build with both provided template and it didnt work, i changed the resolution am i not supposed to do that?
i used 2019 ver instead and it worked

I have a Unity project, where you can nevigate around in a 3D space environment. I’m using Unity version 2020.3.4f1 Personal. I went to ‘Build settings’, chose WebGL, and then clicked 'Build And Run.