Want to mask imported .pod 3d asset


#1

Hi,

I have an animated 3d asset in my scene that I want to hide behind a mask. The normal full 3d plane option doesn’t seem to be working???

any suggestions?

Thanks

Dan


#2

Hello Dan,

An object with layerMode set to ‘full_3d’ will appear over objects earlier in the hierarchy except those with full_3d layering that are positioned closer to the camera.

Consequently, since the mask’s layerMode is set to ‘full_3d’, you need to make sure that:

  • The mask is above the 3D model in the Hierarchy
  • The model and the mask have different coordinates along the Z axis and the mask is positioned closer to the camera. Thus, the coordinate along the Z axis for the model needs to be smaller than for the mask (E.g. if the mask in in (0,0,0), make sure the model is in (0,0,-2)).

I hope this will help. :slight_smile:

Thanks,
Margaux


unlisted #3

listed #4

#5

Hi Margaux,

not sure if you got me email, but the 3d asset doesn’t seem to have a layerMode for me to set as full 3d? As I realisethis would be the normal thing to do, but hence my confusion when I couldn’t find this option?

thanks again

Dan


#6

Hi Dan,

Could you please send your 3d asset over to us at support@zappar.com?

Thanks,
Mark


#7

[EDIT]
Had the same layermode problem so i revived the post but now i managed to solved it!
Thanks

Davide


#8

Hey @developer2,

Would you mind sharing what you did for that?

It can be helpful

Thanks
ayushya


#9

Hi @ayushya
Just double click on the 3d model symbol in the Symbol Definitions Panel and you have full access over your model property including layerMode.

Now in your main scene just turn the opacity to 0 and you got your mask.

Hope this help


#10

Got it! @d.bosco

Thanks a lot for the help.