Video player symbol not playing the URL

Hi there, I’m developing a WebAR experience in the studio, and it needs the video player functionality, so when I placed the URL, it doesn’t play the video.

it just froze and pop up with a warning icon, I’m using a URL from youtube, but it doesn’t play the video,
even after I set up the script of symbol.nodes.Video_Player.nodes.show0.myvid.source(“url]”);
the video still not playing.

is there any solution for this? is it the youtube issue or device issue, cause I’ve already tested in on my iPad pro and Realme 6 pro (android) phone to see if the device is having an issue or the URL issue, and the video still not playin in both devices.

Hi this should help…


1 Like

Playing videos from youtube doesn’t work. It needs to be a direct link to the video, from a CDN for example.

1 Like

Thank you!!

Thank you! May I ask, is there any free hosting service to get the format video that zaps support?

I’ve been using CDN to host videos whose URL end with .mp4 and it’s been working well with ZapWorks studio. There might be others, like AWS I guess but this one I found not to be complicated at all. God bless you!


Great,. it is working !

God bless you ,.

1 Like