Universal AR+Unity+WebGL: blank screen


#1

Ok, so I have tried everything and nothing seems to work.
I made a extremely simple project on Unity 2019.2.21f1, it only contains the prefab for image tracker [Zappar Image Tracker] with a cube as a child and the Universal AR SDK prefab for the Rear Camera [Zappar Camera Rear].

I have changed the “Resolution and Presentation” to WebGL template “Zappar” [not Zappar 2020] and I haven’t changed absolutely nothing else.

I built the project and tried local hosting and Chrome told me the project wasn’t safe. I ignored the warning as a good developer always should do and tried accessing the testing page locally hosted: nothing works. Unity loads and dies.

I then proceded to hosting the project on Zappar test host [https://my.zap.works/projects/]. This allowed me to access the content: yes. But ultimately when the project should show my camera, it doesn’t show anything.

And yes, I have allowed access to the camera in every instance.

Can someone help? I noticed several posts here just die without an answer or solution.


#2

Hi @guilhermefelipe.souz!

I believe that I may have answered your support ticket, but just in case this helps anybody -

We now have a really exciting new update to our Zappar Unity package, which includes lots of improvements! :tada:

You should start to see the update making it’s way to the my.zap.works/downloads page and the dedicated documentation shortly to reflect this change, as we have been hard at work listening to and working on customer feedback.

The new package has been build from the ground up, so you should see that it solves some common bugs such as loading issues and the ability to now see target/tracking images in editor play mode! There’s also a few UI improvements so it should make your workflow a lot easier :muscle:

You can find the new package here - https://github.com/zappar-xr/universal-ar-unity. This newest version has a new and updated README file, which has a different method of installing the package - so please give that a read for more information about how to do so. We also have a couple of updated sample projects for you to try out within this package, which you can read more about on Github.

Have a great day!
Francesca :blush:


White Screen on Unity WebGL build
#3

Hi @Francesca thanks for your answer.

I did download the new version of the SDK package for Unity and I still can’t use the camera in edit mode.
I sent an email to support, but I posted here too, to see if someone have a solution for it.

Thanks a lot for helping us,

Regards,

John

This is a screenshot of the error.


#4

Hi @Francesca,

I have tried a new preview version of Universal SDK and the white screen issue still exists.


#5

I have this white screen issue too! Is this a template issue with the html file?

Thanks,
jrDev


#6

Hi @jrDev and @somshekar,

Thanks for reporting this. I’m going to take a look and try and recreate.

Could you please let us know the Unity version you are using and whether you are using Mac or Windows to build the project?

George


#7

Unity 2021.1 on Mac Big Sur! But that blank screen is showing on the build devices like Mac and iOS Safari, it just takes longer or indefinite on iOS.

Thanks,
jrDev


#8

For what it’s worth, switching from URP to the built-in pipeline seems to have fixed this issue for me.


#9

Hi everybody!

I thought it might be useful to add that the updated package’s Zappar menu actually has an Update Project Settings To Publish option (find out more here) which may help with this situation.

Hopefully this solves a few issues!

Have a great day,
Francesca :blush:


#10

I use the Web Server from Chrome to serve my test projects with NGRok hosting, so this doesn’t really help. I am going to make a video and show exactly how long this is happening for, around a minute before the camera shows.

Thanks,
jrDev


#11

@jrDev What iOS device is taking over a minute? I ask because we have seen that much older iOS devices (iPhone 8 or older) can take a lot longer to init the camera, which is why I display a custom HTML message during this part of the process. Same issue on older Android devices as well.


#12

I have iPhone XR. Also the white screen shows on my MacBook Pro too (though it goes away faster).

Thanks,
jrDev


#13

Hey,

It looks like Zapworks team has fixed this issue in an update email I got today:

We’ve released an update to our Universal AR for Unity SDK, with new features and bug fixes. You can get the latest version of the package from the Github repo - for more information check out the ZapWorks Downloads & SDKs Hub. The following changes are included in the latest version:

Added

  • Train image files directly in the editor

Changed

  • Renamed WebGL templates to - Zappar (for Unity version 2020 and above) and Zappar2019 (for Unity version 2019.x).
  • Exempt additional IP addresses ranging from 172.16.* through 172.32.* from licensing check.

Fixed

  • White screen issue after loading progress on Safari browsers.
  • Fix to update the face mesh view in editor (while toggling between full head mesh).
  • Fix referencing image preview when project GUID has been updated. [Note: finds reference using gameobject name and meshfilter component]
  • Fix camera pause/resume when switching to other tabs and back.
  • Improve HTML template CSS to better fit the full browser window.
  • Issues with other/embedded browsers on iOS, including social browsers.

A big one in on this personally for me too is the training the image inside the editor! Thanks a lot team!

Thanks,
jrDev