Unity WebGL and Image Targets


#1

Hey everyone, having issues uploading to the Experience tab. Using Unity 2019.3.15 and Image targets, which seems to be the problem. Here’s what the error says.


I’ve tried only zipping build and index, but I don’t get anything. Tried uploading just Build, TemplateData, and StreamingAssets. The camera opened, but none of the images I had would scan

Chrome throws this error, but does open the camera

The full Error the software can’t seem to find the targets without the StreamingAssets folder but I keep getting the error at the top when I upload the whole unity Build.
Failed to load resource: the server responded with a status of 404() https://zjcq.zappar.io/7533587387706407363/1.0.4/StreamingAssets/Ship.zpt

Any help would be appreciated. Thanks Guys!


#2

@TreyS
Have you tried uploading via the command-line? You get more info about errors. Perhaps your project is too large? It will fail for projects above 50MB, I think. It will also fail if you upload without changing the version number.

The JS Console says that the code is trying to load your ZPT file and cannot find it in your StreamingAssets folder.

You should be able to upload the whole folder, do not put any additional zip files in there, just:

  • Build (folder)
  • StreamingAssets (folder)
  • index.html (file)

If you use command-line, it will zip and send for you. Run this in the folder where Unity outputs your index.html file, then approve it in your web browser when it comes up:

zapworks publish --project="{project_id_number}" --version="{version_number}" --dir .