(Solved) Black Screen on Web AR


My AR experience works in the Zappar app but not through the QR code. After I go to the web link, it thinks for a second then the screen goes black. Its a modified version of the World Tracking Hotspots free to use project.


I think I read that the Web AR can not do world tracking yet.



It can but you have to have the right specs. When I tried the other world mapping free to use project, it worked but the model just kept sliding around. It also prompted that this device doesn’t support work mapping. Here, it doesn’t revenge get that far. It just goes black right away.

But all of it is fishy becuase if you can do it with the Zappar app and you can do it with other software like 8th wall and glitch then why can’t you do it without the app?


Wad AR is still in bata. also world tracking will fall back on to photosphere if your device doesn’t support it. Whitch your error your getting sound like that is what it’s doing.



Yeah but it would still pop up, not go black. The only issue I see with not having a phone that supports world tracking is the model won’t stick to the floor. But other than that I don’t see any issues that would come from it. And publishing the world tracking projects they give do show up so it must be something I have done. I also checked to see if it was the file size and down sizing didn’t fix the black screen.

All I did was take the World Tracking Hotspots project, replace the engine with a glb SeaDoo model, change the names of the hotspots, replace one of the links to a link with sketchfab and I am trying to figure out how to make one of the other hot spots into a button that makes text appear when you press it but I deleted the code because it wouldn’t let me publish with unfinished code. Its odd because if something is wrong with the code or scene then it should reflect in the zappar app as well right?

Maybe there is a special thing in the project for WebAR that I accidentally deleted. I did delete some stuff I thought was irrelevant to the scene to get the file sized down.

When in doubt, I am just testing the limits of Zappar to see if I should spend my time in the program for the projects I have in mind. So its not a huge deal if I can’t figure this out now but if I can’t then I hope it won’t show up again when it matters.


You can post your zpp file here and we can talk a look at it.
Or you can send your zpp file to the guys at support@zappar.com if there is an error they will let you know. Just a FYI they are in London so it wouldn’t be till tomorrow.



Hi @lawlordp,

WebAR doesn’t support world tracking in the current version. World-tracked experiences launched in WebAR will use the device’s gyro to update its orientation.

I believe the black screen issue is potentially the experience reverting to a gyro state and your model being positioned just in front of the camera or completely over it.

Feel free to send the ZPP of the project to us at support@zappar.com. We can take a look and try to understand what is happening.

It’s great that you’re testing the limits of our tools, we are really excited to see what you can come up with! Don’t forget to post your projects on the show and tell page of the forum.

All the best.



So a general update to this. Image tracking isn’t working either with the QR Code. Same thing is happening. A black screen like the scanner crashed. Is the gyro thing part of all the 3D AR experiences? Or is there a setting on my phone that is blocking the connection?


Hi @lawlordp,

We haven’t had any other reported issues with WebAR.

What device are you launching this experience on?

Can you share the ZPP or the QR code with us (send to support@zappar.com) so we can take a look and see if we can narrow down why this issue is happening?



To close out this and to give the answer on here. The problem is there is a bug with .glb models and webAR. So I guess don’t use .glb for the time being.