Problems importing Universal AR

I follow all the steps, but when I Add from Git URL Unity shows me these errors:

Hi @nikolas.iturregi,

It may be that there is an issue with your Git installation, or the path variable is not set up correctly. There is a handy post on the Unity forums here regarding this which might be helpful.

You could also try the alternative method of installing the package by going to your project’s root folder, finding the ‘Packages’ folder and then defining the universal-ar-unity package as dependency in your project’s manifest.json:

  "dependencies": {
    "com.zappar.uar": ""

Have a great day,
Francesca :blush:

I still have problems doing it manuallyshit2

Hello @nikolas.iturregi,

Here’s couple of things to try:

  • Make sure git command is recognized from your terminal. Use git --version to check.
  • If Unity still complains try restarting Unity Editor and Hub. Note the you’ll have to explicitly close the Hub from windows taskbar.
  • In case you’re using older version of Unity, you may want to switch to LTS or more recent release i.e. 2020.x or 2021.x.
  • You can also try couple of other fixes as suggested on Unity forum (as pointed out by @Francesca).

Lastly if nothing works. You can download the zipped project from here and extract it locally. Then use the add package from disk option Unity package manager to add the package.


Thanks, finally I got it

1 Like