Problem when importing 3D model



Hello, when i import 3D model into zappar it show like the image above, some parts of the model is stretched to other points, i tried importing the same model into game engine (unity) and it worked fine, is there something wrong i did in the max file or while importing the model, thanks.


Hi @hazem.mahaba,

There are a few reasons as to why this model is creating errors on import, all of which can most likely be resolved.

It looks as though when the model has been exported either the bone rig or the animation have caused an error.

You should check out our recently updated 3D Model documentation! This explains, in detail, the supported formats and requirements along with how to export and import 3D models correctly. The supported formats and requirements page gives a clear description of the correct rigs and animations formats.

Hope this helps!



Looks like a cool character, can you tell us a little more about the project you are working on?


It’ happens to me too.

My model turn to a mess when I import into Zapworks, I tried in .obj, .fbx and .glb (this is the faster for me) I checked out the documentation and the model is correct. I don’t know what else can I do to improve the model. Can you help me?


I am having a problem importing a model and its material (using obj, fbx, or glb via cinema 4D). I do the step by step import and I can’t see anything until I select “add a light” then the mesh is missing and I can’t add the material into the material box. What am I doing wrong?