Problem publishing- trackers not working with Zappar app


#1

Hi fam, hope you can help with this one.

I’ve got a very simple project using Zapworks Studio: 1 tracker image per static 3D model. In my project, I have six different trackers and associated models.

When I publish my project, only the last tracker image / model (i.e., the 6th one) in the hierarchy will load in AR when using the Zappar app; none of the others work. If I delete the 6th model and then re-publish with only 5 trackers / models, then only the new last model will work with Zappar (in this case, now the 5th one; note too, this is a different tracker image / model to that deleted). If I then delete that tracker/model and republish, then only the new last tracker / model (now the 4th one) will work… and so on.

I set-up two similar projects last week and had no problems. I’m going a bit nuts.

Hope someone can assist me!


#2

For clarification, you when you say “tracker” are you referring to zapcodes? Currently, Zappar only supports 1 target at a time. So if you hoping to have each code activate a new model simultaneously this will not work.

See this post for more info, Multiple Targets. If that’s not the case you might have to clarify a bit more what you’re trying to do.


#3

Hi Destery,

Sorry if I’m unclear- I’m very new to this. I teach science at a university and want to develop more engaging notes for my students. The aim is to have the students use the Zappar app to scan an image (e.g., a 2D photo of a tree) and a 3D model appears of that tree appears.

I have a single Zapcode for the project. For the target images, I have copied that zapcode and placed it into 6 different 2D images (that I referred to as the ‘tracker’ image in my last post) using a graphics editing program. Each individual image was then ‘trained’ in Zapworks to be trackable. I then drop each one into the hierarchy then bring in the 3D models, then drop one model at it’s corresponding trained image in the hierarchy.

The intention is that when a student scans the image (with zapcode), a single model will appear. Then they move on through the notes and then scan another image, and so forth.

It worked for me perfectly last week for my other two projects (i.e., last week’s class notes), so can’t figure out why when I publish this particular project, only the last image/model in the hierarchy will work in the Zappar app.

Thanks, Gilbert


#4

So you are using multiple tracking images per one code. What you posted that you have done does line up with something @simon posted. https://forum.zap.works/t/support-for-multiple-targets/318/40?u=stevesanerd

I would make sure your are adding the Z.RequiresVersion.v440; that simon said.

I also know there was an update to the zappar app so maybe somethings changed. @simon??

If all else fails you can use my multi-tracking-image-experience code.

Steve


#5

Hi Steve,

Thanks very much for your input.

As I mentioned, I’m very much new to this, so will have to do a fair bit of more in-depth reading.

I still just can’t figure out why it all worked last week, but is giving me grief this week even though I’ve followed the exact same procedure.

In case you’re interested, I’ve attached my class notes for last week and this week THIS FILE TOTALLY WORKS.pdf (1006.2 KB)

ONLY THE THIRD ONE WORKS.pdf (1.1 MB)

For the first file, you can see what I’m trying to achieve. Everything worked. For the second file, it’s currently only got three models as currently published, but it’s only the third one (‘Oats’) that will load with the Zappar app.

Gilbert

ps. I randomly came across your Seven Wonders ancient history work yesterday- absolutely love it! Some of my teaching overlaps a little with archaeology, so was excited to come across it!


#6

Hi Gilbert,

As @steve helpfully pointed out, just add a blank script node with Z.RequiresVersion.v440; and this should work (or add it into any other script node you have).

Your previous project may have used some newer Zappar platform features (perhaps world tracking?) which would mean it would be published by default with a higher minimum version. When publishing, Studio will automatically see the features you are using to ensure any users with old versions of the app will see the “please update your app” message.

The “target round robin” behaviour with multiple target finders is only enabled for scenes with at least a minimum version of 440; it was a behaviour change and believe it or not some older scenes were relying on the behaviour of only the last one loaded being active.

I should say we still wouldn’t really recommend having multiple different TargetFinders in a single project. It is useful in certain cases, but does come with a memory, performance, and file size cost. Can I ask why you didn’t use different zapcodes and projects for the different images? Then each package would only contain the tracking file and content for the image it refers to, which would make loading much quicker for the user scanning their first code.


#7

Hi @simon,

Thanks for your input, much appreciated.

To answer your last question first, I’m very new to this. I haven’t had a lot of time to explore everything that Zapworks can do, but did follow one of the tutorial videos on YouTube and it explain perfectly and simply what I wanted to do- so when I tried it, I got the result that I was hoping for. For the current set of class notes, I followed exactly what I did last week, but hit a stumbling block (for reasons I still don’t understand).

Anyway, I’ll try to figure out how to add the code. If I can’t sort it, I’ll just set-up individual projects / zapcodes for each image in the class notes (class is in around 14 hours, so not much time to do further study about Zapworks before then).

Thanks for your guidance,
Gilbert


#8

Hi @stevesanerd, @simon, and @destery

Reporting back that the addition of the code worked.

Thanks so much, I really appreciate your support.

Will also look forward to getting stuck into Zapworks more when I get some time. I think the scope of using Zapworks for integrated teaching experiences is almost endless.

All the best,
Gilbert