POD models - where to find some?


#1

Hi,
I am still exploring wether I should commit to a seat or not and am having a hell of a time finding any POD format models to use. I am not a 3D modeler, although I have much experience with iClone products, but unfortunately these models cannot be used in Zap Studio.

That being said, is there anywhere to acquire (purchase or free) any POD models? I tried using Sketchup models but these appear with texture inside out or other weird effects.

Thanks for any help


#2

It looks like you can use .obj and .fbx files too, although there are some requirements (listed in the documentation). If those are giving you trouble you can download the power VR SDK which converts your existing 3d files to the POD format. I’m not a 3d person by any means, but after fumbling around with this for a few days that’s what I’ve found to work so far. I’ll include a link below to the download. It’s the same one Zappar recommends. After you download that, open up PVRgeoPOD. then file>open> select your project. (it wont open, which confused me at first). then file>export and that will convert your 3d files to POD files.

Now you can download any free 3d models you want and just convert them to pod. Although I am finding the .obj files to work just fine.

https://community.imgtec.com/developers/powervr/installers/

I hope that helps, good luck!


#3

@sandy is correct, we also support FBX and OBJ: the 3D section of our docs is the best place to go for more info - https://docs.zap.works/studio/3d-models/

Adobe Stock is a great place to get OBJ models from, we recently did a video on it which you can find here - https://docs.zap.works/studio/tutorials/importing-3d-models-from-adobe-stock/

Thanks,
Mark


#4

Thanks for the replies Sandy & Mark.

I have an account on Adobe Creative Cloud so I’ll give that a try. However, I have tried using obj models from several of the sources that you outlined in a blog (turbosquid & free3D) and have found them unusable since they don’t load any textures and I’m left with a pure white 3D model. I’ve tried every several ways to load in the textures but nothing worked. The models were there, but without materials. I was downloading the free models from these sites, so I presumed it was because they were free that they were incomplete.

I will download my 10 free models form Adobe Stock and let you know how this goes.

Thanks for your help and for a wonderful product.


#5

Hi Tom, did you ever figure your issue out? I’ve been having the same problem and also assumed that it was because I didn’t download the full 3D images on Adobe. Still hasn’t worked for me and I’m getting incomplete looking images. :frowning:


#6

Hello Sara,

Are the 3D models that are not working in Studio from Adobe Stock? If so, could you please send them over, so that we can take a look?

Many thanks,
Margaux


#7

Yes, they are 3D models that I bought from Adobe Stock. Here is one of them.
It doesn’t display the actual model, just the hat and scarf!
Where can I upload the file?
Thank you


#8

what is the best email to send them to?


#9

Yes, they are 3D models that I bought from Adobe Stock. Here is one of them.
It doesn’t display the actual model, just the hat and scarf!
Where can I upload the file?
Thank you


#10

I love the idea of things “like” Adobe Stock. I just don’t love Adobe Stock. :slight_smile:

@Mark, any chance you could make a video that uses Collada files from https://3dwarehouse.sketchup.com/

Or this would be even better… a way to import Lego creations made with https://www.mecabricks.com/

Might ask this guy that posts YouTube videos about Lego and Zappar:
https://www.youtube.com/channel/UCzYi6OlcsaUJmAJVtcyp4-g

I don’t know how to build 3D models with Maya, but I can build Legos like a crazy dad superstar! If I could import a Lego creation into Zappar I can think of plenty of fun ideas.


#11

Hello,

@tom and @sara.lemesh, could you please contact us at support@zappar.com and send your 3D models there?

Many thanks,
Margaux


#12

Hey @cluekeeper, the reason we went with Adobe Stock is because they have a strict curation policy which just so happened to mean that the majority of models uploaded there worked within ZapWorks Studio without issue.

We have looked at other stock sites but unfortunately the level of quality has varied wildly with the models uploaded there, making it hard to promote as the place to go to get models for use in Studio.

A lot of 3D models out there require some level of editing in 3D software such as Maya, Blender or 3DS Max and it’s rarely a one size fits all solution with different models having different issues.

Our best advice is to follow the guidlines we have placed on our features and limitations page, making sure your models are either POD, FBX or OBJ.

We’ll be doing our best to improve our model support and provide tutorials and resources on the common issues you may run into moving forward :slight_smile:

Thanks,
Mark


#13

Thanks @Mark that makes sense. So happy to let go of the 3D Warehouse, but still curious about the Lego stuff. :wink:
I tried exporting a Lego creation from https://www.mecabricks.com/ I created an account on mecabricks and made this simple test structure (in about 2 minutes, it’s a super 3D easy tool):
mecabricks

But when I export it as an .obj and import it into ZapWorks Studio (using the same process as your Adobe Stock .obj import example) all I get is the first brick (with no lighting effects so the bumps don’t look great).
https://drive.google.com/file/d/1vIGp5HdMJ8rDv-S9ySH-du2Qz_k2Qnol/view?usp=sharing

So it didn’t work, but to be honest it imported something, which is better than my prior attempts with 3D Warehouse Collada files processed with the POD tool. :slight_smile:

Here was my .obj exported file from mecabricks:
https://drive.google.com/file/d/1DrHcFzH-6OyW9QAAowmUR09mWoVqii4w/view?usp=sharing

Is there a way to see that .obj file in a tool like Maya to see if it was missing the other bricks? I don’t know how to debug the issue. Secretly I’m hoping you’ll say “Just check this magic box in ZapWorks Studio and then that .obj file imports fine” or “You just need to open that file in Maya, check these buttons, export from Maya, and then it imports into ZapWorks Studio fine” :slight_smile:


#14

Unfortunately we don’t have a magic button for you :stuck_out_tongue:

In terms of lighting effects we don’t have dynamic lighting or material support in the platform currently as mentioned in our docs so any lighting needs to be baked into the texture. This might also be the reason why you can’t see the other bricks, that or an issue with the UV map.

Any 3D model ‘debugging’ is best done by a 3D artist as the issues can range wildly, unfortunately no magic Maya settings there either.

Mark


#15

Hello Tom, i am also using iclone, do you find the way to import fbx and animation from iclone to zapworks?
Hope you can advise me.
Best regards.


#16

Hello Elias,

I had to buy iClone 7 pro with 3DXchange Pipeline to get it all working properly. Also, iClone models and props that you purchase from Marketplace won’t export to FBX unless you pay additional money for the export license. That usualy costs anywhere between 2 to 30 USD, depending on the popularity of the model.

Hope this helps :slight_smile:


#17

Hello Tom, thank you for your respond, i have iclone 7.3 pro, and 3dxchange pipline also 7 , and it not working, i am exporting the character fbx from 3dxchange , but it not showing good on zapworks studio.
did you succeeded to export and import it correctly on zapworks ?
if you can share with me, how you did it,.
Thank you .

Elias


#18

Do not embed the textures when you export to FBX from Pipeline. This will place textures into a seperate folder which you then add when you import model into Studio.


#19

Hello Tom, thank you for your respond, may i ask you more details , if you can guide me … will be very good from your side, i success to import fbx from 3dxchange, i am using standard lighting material on zapworks, but when i added animation file from iclone it will not work … mean when i am trying to import the 3d character with animation it will not work, please check the screenshot .
file-6
Can you please guide me, if you can …
Thank you .
Elias