Multiple tracking images using by a single code

Like to know how multiple tracking images that are ‘unlocked’ by a single code

Here is the post where I shared the coding I used for my Ancient History Competition.

There was also so some other good posts and sample code on this post.

If you go down to the end Simon posted that zappar has added some support for multiple tracking images.

Here is a demo that the zappar guys had at there last conference.
Hope they don’t get mad I’m posting them :wink:
I do not have the coding for them.




Here is the original file I used to create the droid multitrack if your interested. I used the approach outlined in this thread, Problem publishing- trackers not working with Zappar app, that includes multiple targets in the hierarchy with the same zapcode.

MultipleTargets.zpp (30.5 MB)


Really appreciated for giving full access to download ancient history project. There is also a video of explaining the breakdown of this project, but as a beginner when I opened project in my computer none is synced with appropriate texture. I have everything in folder but do not know what to connect to which one.
If your team can make a simple tutorial from scratch on this topic, that would be a trending video in Zapworks forum.

That was yours!! I asked the guys if I could get a copy of the code!
This way is so much faster!!



Hi do multiple targets work in WebAR?

I haven’t tried it in WebAR yet. So I don’t know if the web code can. I would open the WebAR page on your device and see what happens when you scan the one on this page.


Thanks for the reply. I tried it with the Star Wars demo project and it worked with WebAR !

I’m trying to use it on my project and have followed everything exactly like that project. I’m using 2 similar targets, each activates a video. Target one works flawlessly and the other doesn’t work. What can be going on? The target 2 activates the video but the tracking is off and wobbly. It looks like it’s trying to find target 1 and they are similar enough that it tries to make it work.

Any suggestions?

One big thing I found is the targets can NOT be the same. Or you will have problems. The more difference between them the better.


Hmmm. Ok, they are not the same but they are similar. I’m going to try with different targets to see if that’s the issue.

1 Like

Hi, thanks for your sharing.

I have tried the same steps in order to create droid mulitrack but it failed.

When I added the trained image in you file directly, it works.

What is the different?
FYR test.zpp (4.3 MB)