Multiple TargetImages and only last trained is working


#1

Hi there,
since 1 till 2 weeks i got a problem with the trained target images. only the last trained target image will work.
first i thought there is some problem on the complexity of my code. that’s why i created a new project and trained 3 target images, picked them in the hirachy and set an on seen event under each.

parent.on('seen', () => {
  console.log('targetImageName');
});

but still only the last one of the tracking images works.


#2

Hey Diana,

That’s right,Studio only supports single image tracking currently.

There are work-arounds though.

You can have a look at this project by @stevesanerd.

Multi-Tracking

Thanks
Ayushya


#3

The problem is not that it not worked from begin. It don’t worked since the last 1-2 weeks. Before the multi ImageTargets worket properly.


#4

Hi Diana,

Multi-target behaviour is only enabled if your project has a certain minimum target version. To ensure it is set high enough, just add Z.RequiresVersion.v440; into a script node somewhere in your project.

More details in this post:

Hope that helps!


#5

Sry for late reply. But i whould test it to say if it is resolved or not. And got no time since thursday.

It’s strange that it worked at start without that. But thank you @simon this is exact what i needed.