Maximum animation length?


Is there a maximum length for an animation timeline? I have an animation where a rack moves along a path of a piece of medical lab equipment, done in Blender. The original animation was about 30 seconds, and I couldn’t get it to play through to the end on the timeline. (following the instructions on the “playing 3D animations” page) I keep speeding up the animation to shorten the time, and have it down to just under 15 seconds. But it still ends prematurely on the timeline.

Is it possible that the easing that Blender usually ads may be ■■■■■■■■ things up? Is the animation just too long? Can I break it up into segments, then play sequentially? Any other ideas?

Thanks for the help!


Still trying to get this full animation into a project. I’ve tried getting it down under 5000 milliseconds, (121 frames at 25 frames per second) and it now shows even less of the animation.

Not sure why this is a problem. I’m exporting from Blender as a .FBX file, are there any known issues with that? Is there a different import format that’s more reliable?


Have you followed these instructions and ensured the model is within the Studio limitations?

(I’ve had success importing FBX models, although not from Blender.)


Yes, I have gone through the instructions. I don’t have enough of an understanding to absolutely guarantee that my 3D file complies with the studio limitations document, but I’m not doing anything special. Just some low poly modeling and movement of mesh objects.

That said, the export instructions are somewhat outdated for Blender, as they show dialogs from 2.7x, which was superseeded by the 2.8x versions last summer. It’s almost the same, but you can no longer select a FBX version to export to. This may be significant, but I have no way to really know.

But, the models export fine, and look really great, and the animation plays as expected up till the point it stops. So if I could just get it to finish the last 10% of the movement, I’d be really happy.

Tried both POD and GLTF versions of the model/animation, and both those formats have siginificantly worse problems when importing.


We’ve had similar problems here. Sometimes the model animation wouldn’t play until the end. Luckily, we were able to get around that by animating in studio using beziers. Why don’t you give that a whirl? Or send an email to


Thanks for the suggestion on beziers, I’ll give it a try at some point once I get past some of the other learning curves of Studio. Currently working with support to see if they can identify the problem. Glad to know it’s not just me…


Hey @buttelmannp I don’t know if you solved the issue but today I received an E-mail from @George that exporting to glb format could solve the problem, and IT WORKSSS!




I have the same problem but here I am stuck at 3333 ms (99 frames) fbx. weird, because on blender I have 175 frames.
Another concern, in fbx this produces triangle artefacts which do not appear in Gltf, but the Glft animates even fewer images.

Someone would have any idea ?



Hi Benj,

Could you try exporting your 3D model with animations to the GLB format instead? This may resolve some of your issues.

Be sure that your 3D model also adheres to the following requirements found here.



Hi Forum!

I may, by blind luck have accidentally solved the .fbx problem of the animation not fully exporting with the 99 number (after a couple of hours of head-scratching.) If you slide the Simplify amount to 0 instead of 1 in the bake animation portion, I believe that fixes the export. I’ve attached a screenshot of my export settings, which I hope might help someone else for comparison with the same problem!


Okay, back again.

I tried out an FBX export for a new project, and my settings above haven’t worked for my newest export. I noticed that perhaps each armature is case dependent for reasons unexplained.

My newest armature attempt has again after many hours this morning trying to figure out why it’s not working worked by blind luck. After trying out many things, I disabled the NLA strips and All actions tabs which has resolved the length problem again to my new mesh and produced a clean result.

This has only one bone, as opposed to the previous model two weeks ago which was a full character amature. The interesting thing is, this method also just worked with a model only containing transform positions for animation, containing no armature at all.

Maybe the settings two weeks ago work for complexity of bone chains? I haven’t tried these new settings yet for a mesh more complex a fortnight ago, but I’ll leave this info for someone else.