Issue with layering .png behind head mask

I am having trouble layering a .png so that it appears behind the head mask within studio.

It does not seem to make a difference where the .png is placed in the hierarchy, it always appears in front of the user’s face and in this instance I am looking for it to be behind.

Any tips appreciated, thanks!

Hello! If you haven’t read through it yet, I recommend looking at the Docs on Face Tracking. Scroll down to the Head Mask section and I think you might find something that’s helpful.

By default, content within a Face Group is not masked, meaning that a 3D model will be rendered entirely over the user’s face.

In cases where a model should be partially obscured by the user’s head, a Head Mask object, which simulates a user’s head, can be used to mask 3D objects positioned behind.

The Head Mask subsymbol is available under the Components section, shown after clicking the + icon in the Symbol Definitions panel.

Also, have you checked the layer mode of the object? I know sometimes setting things from overlay to test_3d or full_3d takes care of render order issues.

Thanks - the Render Sorted tick box and full_3d Overlay setting reordered the layers but there are further issues with the head mask not covering hair, the .png is still visible there and through the eyes.
Could be useful for other projects but looking at doing some other effect now.