Issue mapping texture to 3D object generated from protein data



I am trying to visualize a model that was generated from protein data ( in ZapWorks, but ran into the following problem.

I have triangular meshes generated (tried both POV and OBJ files) and they both upload fine. But the texture file does not show up on the model. I tried applying different texture files (including from existing ZW models), but for some reason they do not work in combination with molecular models.

Have you encountered such problem and what might be the reason/solution for it?

I prepared some POD files (3D (1.5 MB)) so you can compare the behavior of the exact same texture (Heart_CM_TEXTURE_v3.png) applied to two different 3D models, one is a regular mesh (Heart_texture.pod) and works perfectly, while the other one is a mesh created from molecular data (3dtest_texture.pod) and doesn’t display any texture.

Thank you!


Hi, perhaps it’s because you haven’t define the UV mapping information of your model. Made simple, this information tells how to wrap an image onto a 3D object. If so, you have first to import your model into a 3D software in order to create the UV maps. Can you upload an OBJ version of your molecule?


Thank you @jvouillon! The issue was fixed my unwrapping the UVs of our molecule.


Similar issue here! My models are also showing up all white in zapworks, but I do have a UV map on my model. A month ago, I managed to get a textured model to import correctly. I got busy and now I need to document my workflow and can’t seem to recreate the right steps.

I’m working in C4D. I’ve tried OBJ & FBX, straight into Zapworks and also DAE thru the PVR GeoPOD. All the files I import into zapworks are white and have no material channel associated with it. GeoPOD has no sort of preview, so I’m not even sure it’s importing the UV map… I can clearly see my UV map in the C4D body paint window. I’ve saved the baked texture out as jpeg, tiff & png.

What else can I check or do differently? Are there any zapworks updates to accept any other formats? Is there a different workflow I should try? Is there any other application to make POD files?


Please send your .FBX model to for us to investigate further and we can take a look.



Hi, I would just like to know if the issue was resolved?