Introducing Studio 6


#1

Hey everyone!

I’m delighted to announce the release of Studio 6 :slight_smile:

Here are the headline features:

  • Face tracking support
  • Sketchfab integration, allowing you to browse and import from their amazing library directly in Studio
  • Revamped 3D view movement and navigation: holding the right-mouse button allows you to move around your scene using the arrow keys (or WASD), and you can now use the mouse scroll wheel to move forwards and backwards.
  • You can click on objects in the 3D view to select them
  • Studio now supports having more than one project open at once
  • Input boxes can now evaluate simple mathematical expressions for you
  • A brand new color picker: you can now save your key colours on both a global and a per-project basis

For more information you can check out our blog post. There are loads of other smaller changes and fixes so be sure to check out the full Release Notes for all the juicy details :joy:

Existing Studio installations should auto-update next time you start them (open the About window to see the update progress), or you can get the latest version from the ZapWorks Studio Download page.

As always we’d love to hear your feedback - the bits you like, the bits you’d like to see improved, and any bits that are missing - so we can continue to make Studio the best digital reality creation tool out there!

Cheers,
Connell


#2

#3

Woohoo! Great job guys! We’re looking forward creating content with the new possibilities.

Also great that you’re listening to users requests. I love the new multi-window functionality!


#4

I love it!!!

Steve


#5

This is Fantastic. Might I request some face tracking/sketchfab tutorials be linked to this discussion if possible?

Cheers,
Jesse


#6

Hey @jclement!

Good shout - we’re working on plenty of supporting documentation, but here’s some key ones for the new features to get you started:

Getting started with Face Tracking - video tutorial

Getting started with Face Tracking - documentation

Importing 3D models from Sketchfab - video tutorial

Hopefully these will help you on your way. You’re also welcome to request additional tutorials via our new Tutorial Request board :slight_smile:.


#7

I am looking forward to trying today. I had a quick look. I love the new features… still need to try them. I don’t like at all the new navigation buttons… I cannot pan the camera as before and that is a bit annoying… but then I need to get used to… but it was good to be able to just move sideways… is any reason why that was removed?


#8

I thought the same thing. It was very good to the overflow and also I using this system since 2016 or 2017 I can’t remember. I’m happy that the arrows movements through the hierarchy come back but I’m sad that now is harder to move and control the scene without the position button :c

att, Higão.


#9

It is a nightmare. If you choose a view device then the navigation buttons automatically become disable and then by putting back to default they don’t go back to normal again. It looks to me as this is a bug??


#10

Hi @higor @digitalpopups!

This is good feedback - we felt that the new navigation scheme was an improvement overall but will continue to monitor feedback and iterate as we go.

With the new navigation scheme, when you click and hold on the view rotation (the left-most icon) you can use the following keyboard buttons to get the old panning behaviour:
A - pan left
D - pan right
Q - pan down
E - pan up
W - move forward
S - move backward
We’re definitely going to add some on-screen graphics showing these keyboard shortcuts to make things easier. You can also activate this mode by holding down the right-mouse-button anywhere in the 3D view.

Does this help with the lack of the old pan icon?

Thanks,
Connell


#11

Hi, yes that does look like a bug - we’ll look into that one straight away.


#12

Hey thanks @connell,

This is amazing, I didn’t catch it at the first attempt. I thought that this WASD thing was about the arrows on the hierarchy (that’s a wonderful workflow <3).

att, Higão.


#13

Thanks Connell
It didnt work for me I am afraid. I have lost my object now. None of the keyboard behaviours worked. Is there a reset button so I can find the object in space again
I use a wacom tablet and I am not sure if there is anything to do with it… I use a wacom with every software
Please let me know how to reset it.
Glad it worked for you Higao


#14

Yup - there’s a reset option in the hamburger menu at the top right of the 3D view:


We definitely want to avoid the issue so will be looking closely into this.


#15

Thank you. The reset worked but none of the keyboard features.


#16

Understood - are you using Mac or Windows? That will help us track down what’s going on.


#17

MAC . I really don’t like it Connel… I am also left handed which means that I have a wacom tablet and the keyboard which means in order for me to press the ADQSW keys my arm has to go over the tablet… which then it becomes really difficult unless I get a bigger table or turn my keyboard 90 degrees… I use keys with my 3D softwares but they are mostly alt, shift and ctrl which you can find on both sides of a keyboard.
I know people don’t think about all these details. In any case lets get the keys working first then the next step I will have to think about how I can position my keyboard in order to access the keys with my right hand.


#18

I can assure you we do try to think of details like this, but I’m sorry that it’s not working for you. You can use the following arrow keys as an alternative for WASD:
Up arrow - move forward
Left arrow - pan left
Right arrow - pan right
Down arrow - move back
What’s missing there is pan up and down. Perhaps we could make it so holding shift and pressing the up or down arrow would achieve that?
We’ve discovered a bug that we think is causing the keyboard issues you’re experiencing and will let you know how we progress with a fix.


#19

Thanks Connel
I really appreciate the fast response :wink:


#20

You’re welcome - I very much appreciate your feedback and insights as a power user of Studio :smiley:. I’ll keep you posted with our progress.