How to direct the experience(through DeepLink) without pressing Launch button in WebAR


#1

Hi, I want to Zap the experience through WebAR DeepLink, after clicking Deep link it takes me to this page as shown below and I want it to explore directly to experience without pressing launch button and automatically allow for the camera permission after pressing DeepLink, thank you.


#2

I dont think you can or will ever. It’s not a Zappar setting its security setting in your browser. It’s to protect you from hackers. If you allow does it keep coming up or just the first time?

Steve


#3

First time
Thank you @stevesanerd


#4

Then it’s the web browser.

Your welcome
Steve


#5

Thanks @steve - you’re spot on.

For a bit more detail - for certain APIs that are considered to expose too much personal data to web pages the page has to explicitly request that permission first. Camera access is always one of these, and iOS considers motion sensors to be in this category too.

There is another restriction on this permission request - the request for it has to be initiated by a “user gesture” which in practice means you have to call the permission request API from a function that is an event handler for the browser’s equivalent of a “pointerdown”, so it has to be on a normal HTML element, and it the function has to actually get called by the user tapping/clicking the element. The permissions are granted to the domain hosting the page, so it’s also not something you can ask for before following the deep link.

That’s why we need an html landing screen before loading the experience. For enterprise users we offer an option to have a custom subdomain for WebAR which comes with a branded launch screen. That option is quite expensive so tends to only be used by large campaigns or brands, but feel free to reach out to our sales team via the contact form if you want to know more on that.


#6

thanks @simon


#7

Hi, I have stuck from the morning that I made a zap to switching the videos but after the zapping the code through deep link in WebAR whenever I play the video the audio mutes automatically and I need to unmute to hear the sound (as image shown below), can you help me to unmute in the experience starting itself in WebAR and this WebAR works fine in android devices doesn’t mute but it only occurs in iOS devices like iPhone X etc, can you help me do this, thank you.


#8

@vinod - That’s due to another iOS Safari policy. Safari doesn’t allow scripts to start playing videos with sound unless there is a “user gesture” involved - ie tapping on an HTML element.

We do actually use the launch button tap to prepare one unmuted video that can be used by scenes, but if you have multiple videos in your scenes then the additional ones will start muted. The toolbar unmute button (which is an HTML element) will then register a click handler to unmute them. If you can limit your scene to a single video then (I think) it should work with sound straight away.


#9

thank you @simon


#10

Hi is this still the case? Only one video can play sound?
I have an experience that plays 2 videos (that don’t need sound) before it plays the 3rd one that needs sound. By the time it plays the 3rd one, it plays muted unless you tap unmute in the menu.

I’d like to not have have the menu active because it takes up space. Is there anyway to make the 3rd video play sound without having to hit unmute?

Please let me know.
Thanks!
W


#11

Hi @wil,

Please get in touch with us at support@zappar.com and attach the URL of the published project you have mentioned. We can add a query string to your deep-link / QR code trigger to solve this.

George