.fbx with animation not showing up in Studio


#1

Hi guys,

I’ve made a simple 3d object in blender, and keyframed a very simple animation with 2 keyframes. (Box lids opening)

I exported it as a fbx file according to the zappar 3d guidelines. Re-Importing it in blender shows no problems, I can see my mesh and animation (no texture though?), but in zappar it only shows the animated part, not the static mesh. So I can just see the lid in zappar, without the rest of the box.

Exporting it as a .obj shows the whole mesh, but obviously without the Armature (animation) I need. screenshot

This is how my hierarchy looks like in Blender, I select the Armature object (and/or the Cube object, tried everything) and then export it.

Any tips and tricks? Is my workflow flawed?

thanks, 2416b


#2

Hi, I think i can help you export your animation.

https://www.fiverr.com/s2/a0ee5478db?utm_source=com.whatsapp_Mobile


#3

hi idduland,

thank you for your suggestion, but I don’t really wan’t to pay, I wan’t a way to make it myself.

I’ve used another 3D Modelling Software for my task, but I would really prefer a way to make it happen with blender, as this software is free.

The model is not complicated, it’s just a box with an inside and outside material, I can open it in other software with no problem, but zappar just shows the animated part, the lid of the box.

I already tried exporting with the new blender beta, but to no avail.


#4

Are you exporting as one object?


#5

I found for something like this it was easier to make 2 models and add them to the same symbol. Then use your own time line.

Steve


#6

Okay sir no problem i can do it for free if you still want me to work on it. Otherwise good luck…

Idduland.


#7

@stevesanerd

That’s actually quite a genius idea, thank you for that! Animating it in Blender is a more elegant solution, but as long as it works I’m happy with it. I have to look more into pivots in zappar studio to make it work.

@technology
First I tried exporting it as one object, but the problem with the lid (only the moving part visible, and it even moves correctly…^^) occured in Zappar. Then I tried splitting the object into two, it also opens fine in Maya and Blender, but Zappar shows a bigger, second box around the box which is not how I intended it haha

@idduland
Thank you for your kind offer mate, really appreciate it! Still, I want to do this by myself, this just HAS to work, I guess my workflow is somehow flawed.


#8

It might just be a case of scaling each object until they look correct - this has worked for me in the past although it’s not an exact science for obvious reasons.