FBX animation not complete


#1

Hi all,

I’m trying to import a very simple FBX animation as a test file to see if I’m doing something wrong. I’ve animated a cube moving from the origin along the y axis and back to the origin (exciting I know!). Every time I import the FBX animation I only see about 3/4s of the animation and it stops early before returning to the origin. I’ve checked the FBX back in C4D and Blender and the complete animation is there.

I’ve checked the imported symbol in ZapWorks and it’s saying the full 75 frames are in there. I’ve tried adding some extra frames to the FBX file, and it still pauses at the same point, never quite getting back to the origin.

Any help would be much appreciated, I’ve included the FBX in case anyone can spot what is no doubt a user error.
https://proctors.box.com/s/jaibu4fgrpzbhokuibip3fyvtznk63w0

Thanks in advance !


#2

Hello @tim.price I had the same issue months ago and according to the recommendations I exported to glb and it works perfectly.

Regards,

John


#3

Thanks for the reply John, all working fine with glb. Weirdly just tried with a different FBX animation and getting the same problem, at least I know how to get around it now!


#4

Hi @tim.price,

Exactly as @john.lopz has explained, there seems to be a slight issue with FBX animations not running all the way through. It’s something we know about and is something we will look to rectify in the next version of Studio.

In the meantime, glb / glTF models with animation should work as expected.

George


#5

Hi George,

Thanks for the reply, good to know it’s a recognised issue and being resolved. Thanks for the work around in the meantime, not a major issue at all.

Tim