Enviroment Reflection


#1

Hello Everyone,

I’m trying to do an enviroment reflection in a 3D object but it doesn’t work. Do anyone knows if is there a bug or is there a right way of doing it?

I created it on this way:

First I created the object in PBR mode (as it had to be)

Second I created the Cubemap texture, a Directional Light and the Enviroment node:

So I just setted my hdri in the six pieces of the Cubemap Texture and then setted the Cubemap on the Reflection camp of the Enviroment Light node. I don’t know why but the final result was this:

I’ve tried another hdri, increment the light intensity, change properties from the nodes and nothing. I really don’t know what to do now about this.

Anyone can help me out?

att, Higão.


Back Patch
#2

Hey Higor,

It looks like your PBR material only has an albedo map set. The other maps (normal, roughness etc.) are necessary as they describe the surface of the model, and subsequently how it will react to lighting in the scene.

Could you try assigning these other texture maps to the material and see if your end results change please?

Thanks,
Seb


#3

Hello @Seb,

EDIT1: Sent :slight_smile:

I’ve done some tests here and nothing happend, I’ll send you guys the symbol for a further look! I did loots of tests and I really don’t know what to do anymore.

thanks by the att,
att, Higão.


#4

Thanks for sending that through Higor. There’s a couple of issues with the material and lighting set up in your project so I thought it would be good to explain them here on the public forum :slight_smile:

It seems that the same texture map has been assigned to all of the PBR material’s maps. These texture maps describe different aspects of the model’s surface and does so using different representations, meaning the same map won’t work for all of them. For an example of what normal, emissive etc. maps look like you can refer to our lighting materials documentation.

Some of the texture maps (such as roughness and glossiness maps) are specific to the PBR workflow (there are resources available online that better describe this concept) which also need to be taken into account.

The roughness and smoothness maps for example, describe the same surface property (roughness/smoothness) but with different visual representations, meaning they can’t both be applied to a single material.

Lastly, the cubemap texture object takes six different images, which represent each face of an environment cubemap i.e. left, right, bottom etc. In your project it seems that the same image is being passed in to each of these fields, meaning no differentiation is being made between the individual sides of the cubemap. There are online tools available that can split an existing cubemap into six individual images (for each face) such as this one.

Hope this helps. If you have any other questions let me know.

All the best,
Seb


#5

Hello @Seb,

Wunderbar! It works perfectly, also the texture is being repaired to receive this kind of lighting!

Thanks Seb :smiley:

att, Higão


#6

@Seb sorry by the inconvenience but…

I did here and was everything okay, till I test it! Looks like it has a rim light or something like in the object, look:

image

I tried to do some tests changing the maps, colours, texture and also I took a look into the documentation and I saw these codes about StandardLightningMaterials and ToonMaterial. I tried both codes and they return me the default value of the rimLight (as said in the doc it’s 0.6) but when I pass the value of 0-1 on the code, nothing happens.

May I’ve some explanation or help about this? Cause my piece is very weird with this white glow and when Zapped looks a little ugly :frowning:

Standard = https://docs.zap.works/studio/scripting/reference/standard-lighting-material/functions/rim-light-cutoff-getter/

Toon = https://docs.zap.works/studio/scripting/reference/toon-material/functions/rim-light-cutoff-getter/

Att, Higão.


How to edit a JSON File in Studio
#7

Hi @higor,

It seems this might be due to a combination of the way the texture maps are defining the model’s surface, and the lighting set-up.

Could you please send this through to support@zappar.com for us to take a closer look?

Thanks,
Seb


#8

Hello @Seb,

EDIT1: Sent!

Yes I can! I’ll do it in a minute. Through this time, I’ve done some tests and I was able just to minimize this effect but couldn’t make look beautiful or remove all of this effect.

Att. Higão.


#9

Thanks for sending that through Higor.

I’m not getting the same lighting effect on my end, which suggests the issue lies with your light set-up (possibly your environment light).

Best thing to do is to check your environment light’s settings, and the pawn material’s roughness property.

Let me know how you get along :slight_smile:

All the best,
Seb