Easily going over 10MB limit

Hi, I’m trying to test assets in WebGL from unity, but even a (what looks like) simple sword takes the zipped file to greater than 10 MB. This makes it practically impossible to test anything out. Is there a way of making the build smaller?

Hey @jonathanbehr

Thanks for your feedback - I’m inclined to agree so we’re going to take a look at the 10MB limit. I’ll drop you a DM to increase the storage you have on your workspace.

A few things on compression you can try:

  • Optimising assets unity scenes (e.g. model textures/removing unnecessary game objects)
  • We recommend using using Brotli compression with Decompression Fallback option checked in WebGL Publishing settings.

Additionally, make sure you are using the Zappar menu > Editor > Update project to publish settings

1 Like


I have mentioned this before too. Any update on increasing the size limit?


Hi @jrDev,

The Universal AR project size limit is plan specific from 10mb → 100mb. If you’d like to up your limit, please get in touch with support@zappar.com.