Cannot load textures with React threejs library

**Issue: **
Hello there. I have been using the react three-js ar library and cannot seem to debug this issue. It occurs whenever I try to load image textures onto 3d objects.
(React Three Fiber Documentation). The application crashes and displays a white screen. I have tried doing the same thing with the original react-three-fiber components and everything works fine. However, whenever I try doing the same with the ZapparCamera and ZapparCanvas components, this error occurs. Please Help. Thanks.

react-three-js library.

none found yet

1 Like

Hi @kwameadaboh,

Firstly - Welcome to ZapWorks! :tada:

I believe that I have answered your ticket, but in case this helps anybody:

This should not be a bug and you can see many examples of texture loading in our examples here: React Three.js Example Projects :zap:

Two projects you may find helpful specifically are the react-three-example-face-tracking-face-mesh and react-three-example-image-tracking-business-card examples.

If you are having further issues which you believe to be an SDK bug, feel free to comment below and we’ll do our best to help! :rocket:

Have a great day!
Francesca :blush:

Thanks for the reply, I just tried running this example using the qr code ( The camera app freezes when it detects the tracking image. Sorry to bother you again.

Hi @kwameadaboh,

Apologies for the broken example, we have deployed an update to the repository (and @zappar/zappar-react-three-fiber) which addresses the freezing issue.

Thanks for spotting and reporting this! :slight_smile:

1 Like