Blender & Zapworks

Iv’e had no luck importing anything from Blender into Zapworks, even a basic cube. I’ve followed the exportation tutorial trying .fxb and .obj. The preview before importing shows me my model but once I add it and drag it over to the group wher e the demo model lives I get nothing. I’ve attached my files if anyone at Zappar or the Community can help please.
island_painted100.obj (1.6 MB)

1 Like

@xadorlabs looking at your obj file it doesn’t work with zapworks. I get an error loading the file. Indexed Triangle list warning


Has anyone got a fix for the “Indexed Triangle list warning”. Im in Blender. Any help please would be rad!



1 Like

Ok I tried Triangulating a basic cube in Blender and importing it into Zapworks. Still the same problem. Doe’s anyone at Zapworks have a basic tutorial to get a basic object out of Blender into Zapworks? This would be awesome!

Hi @xadorlabs,

Please take a look at our 3D model documentation, more importantly - Exporting (from Blender) and Importing into Studio.

If you are still having problems. Feel free to send across the most up to date model to


What file type are you exporting it as?

1 Like

I’m having the exactly same issue, and the “3D model documentation” doesn’t help I know. It is so sad, did you solve this problem anyway? I appreciate if you share some info that helps.

I had the same issue with support. They defaulted to the 3D documentation that isn’t updated to the current Blender (exporting menu completely different) and I had to throw everything into meshlabs.

1 Like

Same issue here… using glTF 2.0 format help a bit, but then fall into the lighting tuning nightmare that is the second problem. Impossible to get the right material back. I tried many combinaison for hours :confused:

Ok, I found one solution for lighting. With Blender you need to activate Shade Smooth in the object.

Then, you also need to raise Num pixel lights for every material inside your symbol to as many lights you like to have.

I have to change more than 100 materials settings in my model one by one, since multiple selection for settings is NOT ALLOWED…
If you go back to model symbol properties and change the light settings then all your 100 hundred parameters go back to default and you need to start again. You might understand that its not possible to work that way in a production process… Do any member or staff can give a way to change all those settings by once so It don’t take half an hour? Thanks!