Another 404 Unity WebGl problem


#1

All im doing is opening the same Unity Project and building. That is all I have done.

I’ve tried

  • non zipped (just keeps spinning wont upload)
  • zip folder with index, build, and streaming assets
  • zip just build with index inside build folder so its just 1 folder

For the life of me, I can not get it to not show show a 404 error. Please help.

Using unity example repo (downloaded today)
Unity version that the build was, did not change it.
No setting were changed, just build and tried to upload.


#2

I noticed there is 2 webGL templates. I deleted the non 2020 version and checked the 2020 version in build settings and see if that fixes it


#3

404 Not Found

  • Code: NoSuchKey
  • Message: The specified key does not exist.
  • Key: det/6922834112997401732/2.1.1/index.html
  • RequestId: 27DCF5A966E2D4E7
  • HostId: rlHJoONxIU21tzvHrgQcsq5xVia6c1bWAXVujqfE8sk4SCZ0qNkO0vrgEbZ8x8fM5h8vx4KtQtc=

#4

ok, so the zip was creating another folder in the folder. So if someone else has the issue, select the build and the HTML and zip it. do not zip the entire folder.

But now I have a white screen, but better than an error 404


#5

So I mis understood the 2020 html. Thought it an update reference not a unity version reference. I was in the original 2019 LTS. So ill be trying that next to see if it fixes any problems


#6

Alright. So. If anyone runs into these.

  1. Zapper html is for 2019 version, 2020 is for 2020 version. Delete the folder u won’t use.

  2. Do not click on the folder to zip. It will create a summary folder so upload will fail. Select the build files and html and do a zip like that.

And now everything works


#7

Hi @development1,

Looks like you found the solution.

You’ll need to have the index.html file in the root folder that you upload. If you are uploading it with the ZapWorks CLI then it will throw an error if it can’t find it in the root.

We are working on updating the CMS ZIP uploader to also give some more information to help reduce confusion when uploading a ZIP folder without the index.html in the root.

George


#8

this helped me thanks!