Adding normal maps in Zappar


#1

I’m importing a OBJ file from Blender that has a normal map, but when that is placed on the object in Zappar, nothing happens, the object remains textured but with a flat image…

Am I doing something wrong?

Thanks


#2

Hi @technology,

Could you send us a few screenshots of the 3D model’ setup within its subsymbol, and how it’s rendered in the Zappar app please?

Thanks,
Seb


#3

I think I have resolved the issue - by baking all the UV maps I need then importing them into studio seperately, seems to be doing the trick and the AR models are starting to look much better.

Thanks


#4

How did you apply the textures separately as I’m having the same issue.

Did you drag your model in and when it asked for the textures you then applied then one by one?


#5

They have to be applied to the model in whatever 3D programme you’re using, then when importing to Zappar you get the option of how you import - you need to select the Albedo settings and all your textures will then need to be uploaded and reapplied to the model. Takes time and is not a perfect science by any means!


#6

Hello Technology,

After speaking to the guys at Zappar it turned out that I was actually doing everything correct. The issue is with Zapworks and it will be addressed in the next update. When importing the Normal Map into Zapworks from a Mac, it was seen as a standard image map. The guys at zapper took my files onto a PC and it imported fine.

Drove me bonkers as it appears I was fighting a loosing battle.