Videos not linking



So i’m new to Zappar and i’m trying to embed videos. I can see a YouTube option and a Vimeo option but neither links work. I keep getting an invalid error with an X next to the link whenever I paste them.

Either i’m doing something wrong or the functionality isn’t working.

Anyone else had a similar issue?


Hi @garen,

Could you send the through the video URLs you’re attempting to add to your experience please, and let me know which of our ZapWorks tools you’re using?

I’ll be able to take a closer look and see what’s happening.

All the best,


Hi Sebastian,

I’ve tried linking many YouTube videos but I keep getting an invalid error with the X mark next to it.

This is using the Designer tool.

Some links i tried:

I tried using only the end part of the URL too and that didn’t work either.

This could also be a firewall issue on my end. I’ll try to do this from my home PC later too.



Thanks for sending those through @garen.

I’ve managed to add these successfully to Designer so it could be your firewall as you mentioned.

When you get a chance, could you let me know if it works on your home PC please?



I had this happen to me too. I was using the Brave browser at the time. I then switched to firefox and my youtube links worked fine. So possibly it’s a browser issue.