Possible bug in 4.0


#1

Hello,
I have been trying for the past hour to get my video to play in the 3D view using Studio 4.0.

I have followed the exact instructions found in the guide : https://docs.zap.works/studio/video-in-the-3D-view/

It does not work.

Here is a ling to my project folder zipped on wetransfer : https://we.tl/P5Sjv3DdVV

Am I the problem or is there a bug?

Thanks for any help.


#2

Hi Tom,

Sorry to hear you’ve been having trouble with the new version of Studio.

I’ve downloaded your files but it seems you haven’t provided the project .ZPP file, and unfortunately I can’t open your project without it.

To grab the .ZPP file, you’ll want to hit the export button in the top left of Studio, select ‘Export Whole Project’, and tick the ‘Include Commit History’ checkbox. Once you’ve grabbed the .ZPP file could you send that over please and I’ll check it out for you?

Thanks,
Seb


#3

Hello Sebastian,

I actually found what was causing the problem and it isn’t a bug with 4.0.
I tried changing the video resolution and bitrate to match a previous project that I had zapped and the problem was solved. It seems that the best video setting for video in the 3D view (as material on plane) is as follows:
1280 x 720
Data rate 1196Kbps
Total bitrate 1319 Kbps
29 fps

Audio:
Bitrate 123Kbps
Stereo with sample rate of 44kHz

These settings work perfectly and also generate a relatively small file size making them perfect for video that is integrated into the zap project.

Thank again for the quick response. You have an amazing platform and I’m learning more and more each day on how powerful it can be!

Have a great day
Tom


#4

Hi Tom,

I’m glad you managed to solve the issue, and even more so that you’re having fun using our AR tools!

When using video in your zap experience it’s always good to double check that the video uses the recommended format and bitrate. This is explained in the link below:

https://docs.zap.works/studio/scripting/reference/video/

If you ever run into any other hiccups feel free to email us at "support@zappar.com", we’re always happy to help. In the meantime, keep having fun with Studio!

Thanks,
Seb