Masking a VideoPlayer


#1

Hello,

My goal is to get a video inside a hole in the wall. Here is what I get so far :

I am streaming a video, using the VideoPlayer node. It works all right.
I am masking several 3D objects, using a Square Mask node. It works all right.

The problem : I would like my video to be hidden by the Square Mask, but I can’t find any way to make it work.
The VideoPlayer node does not have a “layerMode” attribute (so it can’t be set to “test_3d”).

Do you know a solution ?

Thanks.


#2

I had a hard time getting my mask to work right with 3d object. I found that the position settings and the where is in the tree on the left make a big difference. Make sure the video is before the mask on the left and the position setting is set behind the mask.

Hope this helps I haven’t masked a video yet.

Steve


#3

Thanks Steve.
I already did all the settings recommended on the documentation, and it works perfectly for 3D objects.
But it doesn’t seem to work for a VideoPlayer.


#4

I made a test file for you.
I had to open videoplayer symbol on right. In it look to the left and change Plane0 to test3d.

video test.zpp (3.5 MB)

Steve


#5

Yeessss !
Thank you so much !

I didn’t know you could modify a VideoPlayer like that.

Cheers.


#6

I’m glad to help. :smile:

Steve