3D Model not showing in preview or published views


#1

Hello!

I have following the instructional video and uploaded a 3D model into the Zapworks Studio and in the building interface, everything looks like it is going perfectly. However once I preview it, absolutely nothing appears when I zap the code.

I have tried using both .obj and .pod files and both have the same result. In the studio the model shows, textures and all, and I can manipulate it and include a training image but absolutely nothing shows up when I preview it or publish it.

Any help would be greatly appreciated!


#2

You have to move to the parent symbol “bruce4” and put the symbol “mooseOBJ” within the root and, better, relative to a tracking image, in order to move it moving the target. It’s very simple!


#3

Hello,

As Marco was saying you’re in the 3D model subsymbol currently, you need to return to the parent symbol ‘bruce4’ by clicking on it in the breadcrumb bar above the 3D view.

Then when you’re in your parent symbol you need to make sure you have created an instance of your 3D model by dragging the symbol from the Symbol Definitions panel into the Hierarchy, this should make it appear. This process is covered in this page of our documentation, particularly the final section - https://docs.zap.works/studio/3d-models/importing-3d-models/

Cheers,
Mark